Results 1 to 7 of 7
  1. #1


    Member Since
    Oct 06, 2010
    Location
    County Armagh Northern Ireland
    Posts
    96
    Specs:
    2015 iMac (late 2013) 21.5", 2.9Ghz i5, 16Gb Ram, Nvidia Gt750M, 1Tb Fusion Drive
    Problems importing media to mac
    I have tried recently to import video files from my camera to my imac via final cut pro x.
    In the past this is something which never caused any issues. However recenlty i get this message:

    1.jpg
    The camera is a sony DSC-HX100V which saves in AVCHD format. I normally plug the SD card into the back of the mac and import media that way, however this time the mac didnt recgonise the video files on the SD card when i browsed for them on finder. The card has been formatted on the camera.
    i had to remove the files on a windows computer and use handbrake to convert them to MP4, this was strange as final cut could show the video files were there, finder and image capture couldnt.

    I have now tried to import videos with my iphone and am getting similar issues, final cut wont show any video footage of new video clips:
    2.jpg
    This is the clips when imported:
    3.jpg


    The same video clip when imported into photos
    4.jpg
    This is a clip recorded on an iphone 7, i have never had such issues in the past:
    5.jpg

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    7,163
    Specs:
    Mac Mini i5 (2014 High Sierra), iPhone X, Apple Watch, iPad Pro 12.9, AppleTV (4)
    OK. I think these maybe two separate issues.

    For the Sony import - is Image Capture able to copy the file(s) across to your Mac?

    For the iPhone import - What version of Mac OS do you have? I suspect the issue here is that you're recording in HEVC (iOS 11) but the version of Mac OS you're running can't read HEVC.

    Again - Can Image Capture import these files OK.
    Is final cut up to date?

    Please use the reputation system if you think you've been helped - bottom left of this post

  3. #3


    Member Since
    Oct 06, 2010
    Location
    County Armagh Northern Ireland
    Posts
    96
    Specs:
    2015 iMac (late 2013) 21.5", 2.9Ghz i5, 16Gb Ram, Nvidia Gt750M, 1Tb Fusion Drive
    Hi there

    These are the versions of what i am running
    Late 2013 Imac with OSX High Sierra 10.13.1
    Iphone 7 with iOS 11.1.1
    Final Cut Pro X 10.3.4
    Photos 3.0

    Everything is up to date, and i suspect these issues have happened since the most recent import.

    Image capture nor fineder would show up the media on the sony cameras SD card, final cut would show it was there but wouldnt import it. I had to import it on a seperate windows computer, convert to MP4 and bring it back to the mac.
    Trying again tonight if i plug the SD card into the back of the mac finder shows its there but will not show any raw footage files, only final cut shows that it has footage but i cant import it

    The iphone ive changed the camera resolution to 1080p 60, now photos and image capture work fine, but final cut will still not show its footage. Having said that previously the iphone sat at 4K resolution when recording videos and no programs had any issues.

    One other device i have tried is my Gopro hero 5 black, if i plug its SD card into the imac it works fine, footage imports into final cut without any issues.

  4. #4

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    7,163
    Specs:
    Mac Mini i5 (2014 High Sierra), iPhone X, Apple Watch, iPad Pro 12.9, AppleTV (4)
    iOS 11 brought HEVC packaged video. Final Cut has yet to be updated to handle HEVC. An update is expected 'soon'. As a workaround you can change back to MP4 in Settings - Camera - Format - Most Compatible for all future recordings.
    In the interim I think Handbrake can transcode from HEVC containers.

    The Sony issue is an odd one. Finder should show the files on the card regardless of type. Do you know what file system the SD card has been formatted to?

    Please use the reputation system if you think you've been helped - bottom left of this post

  5. #5


    Member Since
    Jan 20, 2018
    Posts
    2
    Video not show in Photos 3.0 from SD card used in Sony camera
    I've got the same problem. Videos no longer show in Photos when insert SD card into iMac. I've upgraded to Photos 3.0. When I put same SD card in my laptop which is still running Photos 2.0, the videos are there. So seems it's the Photos 3.0, perhaps only with SD used in Sony camera. Please set me know if you've got a fix as now I've got to go into finder and taxes several steps going into "Private" folder, and then finding video in AVCHD and then BDVM and finally opening it with QuickTime Player. Can only do one video at a time

  6. #6


    Member Since
    Oct 06, 2010
    Location
    County Armagh Northern Ireland
    Posts
    96
    Specs:
    2015 iMac (late 2013) 21.5", 2.9Ghz i5, 16Gb Ram, Nvidia Gt750M, 1Tb Fusion Drive
    Still having problems with the sony camera
    I have found that the files can be found by going further into the SD card and opening package contents to get MTS files.

    I imported media to final cut the other day, it seemd to work fine, but the camera icon appeared beside the media and it says "This item cannot be shared while it is still referencing media on the camera"

    I had perian on this computer in the past, the sony puts out video in AVCHD format although if it all worked before id expect it to work again.

    An absolute headache, id consider buying a replacement camera but most are using the same format anyhow.

  7. #7


    Member Since
    Jan 20, 2018
    Posts
    2
    1. Spent a lot of time online with AppleCare and best they could recommend was using iMovie to open the videos stuck on AVCHD.

    2. I found it much easier to go to Finder, and open the SD card, click on "Private" and then go to the AVCHD folder, click on "Show Package Contents" which opens a BDVM folder, and then "Open with" that folder using QuickTime, and all of the videos on the SD appear on a screen. Go to File on Quicktime menu, and "Export To" and you can put the video wherever you want.

    3. I don't know about your Sony camera, but when I go to look at my videos on the camera screen, I go to Menu and click "Playback", and then "Still/Movie Silect". Whenever I did that I saw there were two options for movies, AVCHD or MP4, but my movies were on the AVCHD file. I realized that's what's the problem, and went to the Instruction Manual for my camera, and found how to switch the mode for recording movies from AVCHD to MP4. I did that and now all my movies appear right away in Photos when I put my SD card into the slot on my iMac. So the way I described in 2. above is only needed to move old movies from the SD card to Photos, going forward I can import movies at the same time i'm importing photos.
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems importing photos from camera
    By audax2 in forum macOS - Apps and Games
    Replies: 5
    Last Post: 02-21-2014, 04:48 AM
  2. Importing files from Windows Media Player :Confused:
    By delsutton in forum Music, Audio, and Podcasting
    Replies: 4
    Last Post: 01-31-2010, 10:36 AM
  3. problems importing into imovie
    By ek64458 in forum Movies and Video
    Replies: 1
    Last Post: 07-04-2008, 08:25 AM
  4. Problems importing to iMovie 6.04
    By geofcoulson in forum Movies and Video
    Replies: 2
    Last Post: 01-25-2008, 08:41 AM
  5. HELP!!! - iTunes Importing Problems
    By jblanco99 in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 09-24-2007, 05:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •