Results 1 to 5 of 5
  1. #1
    iMovie Source Clip is Missing?! Please Help!

    Member Since
    Feb 03, 2013
    Posts
    17
    Exclamation iMovie Source Clip is Missing?! Please Help!
    Hi, I am making videos with imovie, I was recording a game but then it stopped because my disk space was full. I checked my storage space and all of my movies, music, etc. was gone, it was all other. I deleted a lot of movies and recordings I thought I would never use again. I made sure I kept ones I wanted but I deleted the ones that were already in iMovie. I thought that because they were in imovie it would still work. I got on iMovie about an hour later and I imported something from my event to my project, then I went to upload to youtube. It was all working but when I cancelled the youtube uploading, the project and everything in it said source clip is missing but it was all still in my events. I quit iMovie and opened it again and this time all of my events were empty, and all my project clips had a yellow triangle on them and it still said source clip is missing. Now, I had iMovie OPEN when I deleted all those movies, and didnt close it since, so maybe the events didn't delete until I quit it. I don't know though. Is there ANYWAY I can get those clips back!!!!!!!!!!! Please!!!!!!!!!!!!!!!

  2. #2
    iMovie Source Clip is Missing?! Please Help!

    Member Since
    Apr 20, 2010
    Posts
    472
    Specs:
    21.5 iMac 3.06 ghz 12gb ram 500g HD iPad 2 16G
    From a backup...otherwise goodbye...unless you go down the 3rd party software recovery road.

  3. #3
    iMovie Source Clip is Missing?! Please Help!

    Member Since
    Feb 03, 2013
    Posts
    17
    Unhappy
    Really?? That sucks!

  4. #4
    iMovie Source Clip is Missing?! Please Help!

    Member Since
    Apr 20, 2010
    Posts
    472
    Specs:
    21.5 iMac 3.06 ghz 12gb ram 500g HD iPad 2 16G
    Did you empty/check your trash...?

  5. #5
    iMovie Source Clip is Missing?! Please Help!
    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,758
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    I've moved your post to a more proper forum; please be sure to check the forum descriptions to find the best place to post.

    By posting in the right forum you help people not only find your question faster, but it helps others looking for the same information in the future.

    Thanks for understanding!
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMovieSpeedConversion source clipping missing issue
    By Zabitudo in forum OS X - Apps and Games
    Replies: 3
    Last Post: 11-25-2013, 06:53 PM
  2. FCE missing dialog asking if clip and seq settings match
    By shandelsmanmd in forum Movies and Video
    Replies: 0
    Last Post: 12-04-2010, 12:09 AM
  3. Source clip is missing
    By scottc in forum Movies and Video
    Replies: 0
    Last Post: 02-25-2009, 09:14 PM
  4. clip delay in iMovie
    By anarchyphreak in forum Movies and Video
    Replies: 0
    Last Post: 05-13-2008, 05:33 PM
  5. iMovie: Clip question...
    By MACyMouse in forum Movies and Video
    Replies: 3
    Last Post: 05-13-2006, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •