Hey,

Working on a new iMac and have the sealed upgrade version of FCS3.

Had FCS2 on an old computer.

Here's my question.

Do I have to first install FCS2 on my new iMac in order to be able to install FCS3 upgrade version? Or can I just install the upgrade version and enter the serial number from the FCS2?

Thanks!