Results 1 to 4 of 4
  1. #1


    Member Since
    Jun 14, 2018
    Posts
    1
    Can’t erase SD card that is unreadable by iMac
    I have a MacBook Pro and a 27 inch iMac that are both using macOS Sierra v 10.12.6. I have a San Disk 64GB SD card that is unreadable by either of my apple computers. I have followed the steps to use disk utility to erase and rename my card but when I click “erase,” I end up with the message “erase process has failed.” When I click on “show details” it says “MediaKit reports not enough space on device for requested operation.” What gives? Did I waste 40 dollars on this SD Card? Do I need to by a windows computer just so these types of things can be more easily fixed?

  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    24,825
    Specs:
    iMac, i7 4GHz, 32GB memory, 1TB Blade Drive, OS X.13.5
    SD cards have a high failure rate. Take it back.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    55,611
    Specs:
    2017 27" iMac, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, Numerous iPods, High Sierra
    Check the card closely to see if it has a "read-write" switch. Sometimes they're hard to spot. If it has one, just set it so that you can write to the card and then you will be able to erase and format the card. If that particular SD card has no read-write switch, then it's probably defective and should be returned for a refund.

  4. #4

    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    4,157
    Specs:
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS Sierra 10.12.6
    Hi Ricky

    I agree with the comments made by ny senior colleagues.

    Just one additional thought. You imply that Disk Utility can see the card when mounted.

    Does it just show one volume or is there an indented volume below the name of the card?

    If there is an indented volume shown, try clicking on that one and formatting the disk.

    If still no luck, then replace it.

    Ian
    Ian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disk Utility won't let me erase a SD Card
    By JCLanz in forum macOS - Operating System
    Replies: 15
    Last Post: 06-14-2017, 07:17 AM
  2. Micro SD Card shows read only and all format/erase options are greyed out
    By dingdingdang in forum macOS - Operating System
    Replies: 9
    Last Post: 06-20-2016, 07:15 PM
  3. Erase iMac G5
    By jerry2090 in forum Apple Desktops
    Replies: 2
    Last Post: 05-08-2012, 07:03 PM
  4. Can my imac erase my PC
    By flimson in forum Switcher Hangout
    Replies: 6
    Last Post: 03-09-2009, 08:59 PM
  5. memory card unreadable....
    By Computer.Geek in forum Apple Notebooks
    Replies: 0
    Last Post: 02-06-2006, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •