Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24
  1. #16
    WiFi connected to router, but not to internet

    Member Since
    Aug 28, 2010
    Posts
    1
    same issue but no DNS
    Hi, I`m also experiencing the same issue, the problem is, there is no DNS entry showing in the settings of my home Wi-Fi! Did you all have them in there? How can I find out what number - dns entry - to manually type in to that field? please help, I got my Iphone just recently and its really annoying that I cant use it at home! thanks


    Quote Originally Posted by mshale View Post
    I found a solution!!

    Yep, that solved my problem too. So a precise walkthrough for the solution:

    1) Go to settings, Wi-Fi, choose the network and hit the blue button. Touch "Forget this network" and confirm.
    2) Now go back into Wi-Fi settings, choose the network again and join it.
    3) Now hit the blue button and go down to the DNS line. Select the line and drag your finger to the left until you find the first DNS entry (entries are separated by commas). In my case, for instance, the first entry was 192.168.1.99--a local address on my network.
    4) Use the backspace button to delete the first DNS entry.
    5) Touch "Wi-Fi Networks" to go back.
    6) Open safari and try visiting a site by URL: Apple for example.

    This worked for both my iPhone 3G and iPod Touch. There was no need to reboot the router, reset my network settings, or anything like that--just follow the steps above.

    Incidentally, the DNS address I had to delete--192.168.1.99--was actually a static address on my network that I had allocated to my printer. So it was a very bad guess on the iPhone/iPod Touch's part as to where the local DNS server would be. But someone else's comment rings true, that the bug seems to be in the iPhone OS and has to do with falling back to the next DNS address if the first one fails--or falling back in a timely manner.

    Yeah, you're welcome, Apple engineers. We're happy to do your work for you and pay for it too!

  2. #17
    WiFi connected to router, but not to internet

    Member Since
    Oct 09, 2010
    Posts
    1
    help
    I am having the same problem here, I have tried reseting all settings and network settings. Also went to the Network and copied tne DNS that I have on another iphone but didn't work. IP address and subnet Mask are different as the other iphone, specially the Ip address is not even similar. Any suggestions? I am not very computer literate.
    This problem is driving me crazy since I don't have service at home so I rely on WiFi.
    Thanks.

  3. #18
    WiFi connected to router, but not to internet

    Member Since
    Oct 21, 2010
    Posts
    2
    Unhappy Any other idea?
    I tried all of your advices, nothing worked for my iphone 3GS. I had only one DNS entry there, but that case is alredy mentioned here too...and still nothing. I have to add that i'm experiencing this problem with every wifi I try to connect to, while opening web pages via standard 3G connection works perfectly. Does anyone have any other idea? Thanks a lot...

  4. #19
    WiFi connected to router, but not to internet

    Member Since
    Oct 21, 2010
    Posts
    2
    Cool Solved!
    Yaay, I've found a solution - it's simpler than you think iPhone Wi-Fi/EDGE problems? Reset network settings | iPhone Atlas - CNET Reviews

  5. #20
    WiFi connected to router, but not to internet

    Member Since
    Dec 28, 2010
    Posts
    1
    The perfect Solution
    This has worked perfecly , thankyouu very muchhh Pal!

  6. #21
    WiFi connected to router, but not to internet

    Member Since
    Feb 08, 2011
    Posts
    1
    Quote Originally Posted by AlaskaLiz View Post
    Yay! I don't know why it worked, but it did. I ran through Apple's protocol to fix it and nothing happened. I had just one DNS listed, so I deleted it. It came back. Deleted again, and this time a typed in one from my MacBook that was connected to the network. It worked! Thanks.
    I have O2 broadband, I have the same issue. After entering the wifi password, I clicked on the blue button to see the IP address. It was starting with 169.xxx.xxx.xxx and no DNS. It should be 192.xxx.xxx.xxx

    I looged into the Router "http://192.168.1.254/" in case of O2 and may differ by different providers. I saw the encryption password was different to what I typed in IPhone. What I saw in IE was the original password came with my router. I hooked the problem was, Once a laptop or other devices once connected to the router and if the router is reseted to factory settings, it connects to wifi without changing the password again. where we try the Iphone with the password which was once configured for the router. So the wifi is connected but not the internet. After changing the password, I got the internet immed. I also changed the cannel in the configuration page, but I beleive it does not matter.

    Anybdy having this problem can check your password is correct. My Iphone connects to the Wifi even I type the old password once configured to the router and resetted to factory settings. If this is your case, This will solve the problem.

  7. #22
    WiFi connected to router, but not to internet

    Member Since
    Mar 26, 2011
    Posts
    1
    worked for me
    I had the same problem, also only at home. My network is slightly more complicated though. I have a Netgear wireless router which connects to one pc and a belkin G wireless router. The belkin connects to another pc and an xbox 360. i have the wireless turned off on the belkin because I though it might be messing with my ipod but that had no effect. I have had problems with it in the past (one port doesn't work, wont let me turn off dhcp, wifi works sporadically). This fix worked with no problem. Haven't tried to turn the wifi off on my ipod yet though. Have had a little lag on the xbox but nothing too serious. It does seem wierd to me that it would be an the ipod's issue but you guys would probably know better than I would.

  8. #23
    WiFi connected to router, but not to internet

    Member Since
    Dec 12, 2011
    Posts
    1
    Cool Simple iphone fix
    Quote Originally Posted by AlaskaLiz View Post
    Yay! I don't know why it worked, but it did. I ran through Apple's protocol to fix it and nothing happened. I had just one DNS listed, so I deleted it. It came back. Deleted again, and this time a typed in one from my MacBook that was connected to the network. It worked! Thanks.
    SOLUTION:
    1) Forget network encoded or set at iphone settings to default(reset network settings)
    2)Reset your router for 1 minute and boot it up again. Problem solved with my 3 Iphone 4s 32gb , 16gb and 8gb fixed all of mine in no time and detected wireless!!!

  9. #24
    WiFi connected to router, but not to internet

    Member Since
    Jan 30, 2012
    Posts
    1
    On similar topic
    Quote Originally Posted by mshale View Post
    I found a solution!!

    Yep, that solved my problem too. So a precise walkthrough for the solution:

    1) Go to settings, Wi-Fi, choose the network and hit the blue button. Touch "Forget this network" and confirm.
    2) Now go back into Wi-Fi settings, choose the network again and join it.
    3) Now hit the blue button and go down to the DNS line. Select the line and drag your finger to the left until you find the first DNS entry (entries are separated by commas). In my case, for instance, the first entry was 192.168.1.99--a local address on my network.
    4) Use the backspace button to delete the first DNS entry.
    5) Touch "Wi-Fi Networks" to go back.
    6) Open safari and try visiting a site by URL: Apple for example.

    This worked for both my iPhone 3G and iPod Touch. There was no need to reboot the router, reset my network settings, or anything like that--just follow the steps above.

    Incidentally, the DNS address I had to delete--192.168.1.99--was actually a static address on my network that I had allocated to my printer. So it was a very bad guess on the iPhone/iPod Touch's part as to where the local DNS server would be. But someone else's comment rings true, that the bug seems to be in the iPhone OS and has to do with falling back to the next DNS address if the first one fails--or falling back in a timely manner.

    Yeah, you're welcome, Apple engineers. We're happy to do your work for you and pay for it too!
    Hi this did not solve my problem but made me click
    my computer sometimes has problems with dns so i use the google dns 8.8.8.8. and never had a problem and phones worked fine too, then windows chucked up an error with do you want to apply dhcp fix, natural i click ok and net worked fine, but made my two iphones not work and yet my laptop still worked, i have a d-link btw. anyway this really puzzled my i kept rebooting router restarting and such checking firewalls etc. etc. turns out i followed your method and just backspaced the dns and put 8.8.8.8. worked sweet, im sure there is a much more technical side to it, im happy to just have it running with a fast server thank you for your post i hope mine will help somebody too!

    p.s. i recently upgraded os on phone and installed a printer, and connected the laptop, so lots of troublshooting, funny thou laptop had dns as 8.8.8.8. from before so i forgot ;p but i dont know why the phones worked up until windows made me apply the fix on it's own. all good yay

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why am I repeatedly asked for a password when connected to wifi router?
    By Alwyn in forum iPhone Hardware and Accessories
    Replies: 4
    Last Post: 03-29-2012, 09:51 AM
  2. Connected To Router, But What About Internet?
    By MontanaMac in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 10-10-2011, 02:11 PM
  3. Connected to router but no internet
    By Del in forum Internet, Networking, and Wireless
    Replies: 28
    Last Post: 10-27-2009, 04:33 PM
  4. Airport Extreme problem: no wifi when connected to router
    By dimlocator in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 05-07-2008, 02:10 PM
  5. Connected to my router but not to the internet??
    By jim182 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 12-26-2007, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •