Results 1 to 11 of 11
  1. #1

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    keychain not working on IOS devices
    Years ago, the Apple commercial stated that Apples just work. And they do--until they don't. Getting answers ain't so easy; thankfully MacForums is here
    Not that long ago, while on vacation, I used my iPad to do some work that required me to access accounts that have always been easy to open on my iMac as the important info needed was saved to keychain. When I got home, I investigated why keychain had not worked on my iPad nor on iPhone-to no avail. All my IOS and OS devices are up to date. In my OS sys pref/icloud, keychain is checked. In my IOS settings/name/icloud, keychain is set to ON. The first bit of info I found told me to turn off keychain and reboot. There was my first prob. I am unable to turn off keychain. I have tried on both iPad and iPhone. After following the dirs, keychain comes back on by itself. How am I to turn off keychain, if I am not allowed to do so? Searching for more info on the pitiful apple community site, all I see is info dealing with earlier IOS and/or I am told to do things that I don't see on any of my devices, such as 'advanced' tabs to click, etc. So, is there some advice from this forum that can lead me to making keychain workable on my iMac, iPad & iPhone? My devices are now at OS:10.13.5 & IOS: 11.4 .

  2. #2

    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    4,157
    Specs:
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS Sierra 10.12.6
    Hi tape. Nice to see you again.

    If it is the case that on all your iDevices and on your Mac(s), you are signed into iCloud and keychain is selected to be synced - then I would simply sign out of iCloud, then sign in again. I'd probably start on the Mac(s), then the iOS devices.

    Signing in/out of things in general often "resets" the system and gets things going again.

    Worth a try anyway. And please do post back.

    Ian
    Ian

  3. #3

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    Ian,
    My only concern is signing out of all devices and needing my iPhone for the code signing back in

  4. #4

    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    4,157
    Specs:
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS Sierra 10.12.6
    That shouldn't be a problem. Sign in/out of the Mac(s) first. I'm assuming you are referring to 2FA and expect a 6 digit code on your iPhone. You will get that, or maybe not, as your Mac(s) are trusted devices.

    Then get started on your other iDevices, leaving the iPhone till the last.

    What are the other options? Syncing of Keychain is not working no matter what you do. You need to reset/recharge the system. Signing in/out does this.

    If you're uncomfortable with this, I understand; perhaps some of my senior colleagues here will have something else to offer.

    Ian
    Ian

  5. #5

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    Ian,
    I did as you suggested. After turning off icloud on each device (iMac, iPad then iPhone) I powered down each and restarted. Signed on to icloud in the reverse order, made sure all settings were as they should be and again rebooted all devices. I did not save any info to devices upon shutting off icloud. All my documents in icloud. When I check keychain access on my iMac via Launchpad, I do see the info saved there is indicated as being in the cloud. Clicking on different links on my iMac shows that the info in keychain is indeed there and is working. I started up an older macbook that I used for traveling before my ipad and after updating everything on that device, I also find keychain fills in usernames and passwords as does the iMac. However, when I try this on my iPad or iPhone, I get nothing but a blank space. I see a little key icon when I attempt to log on to sites in iMac or macbook, but no icon on either IOS devices. Settings/Name/icloud/keychain is turned on. Safari/autofill on. Settings/accounts&passwords the list shows the same as the passwords in my iMac safari/pref/passwords. All my devices are approved. I am at a loss. How do I get keychain to be used by my IOS devices?

  6. #6

    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, USA
    Posts
    4,295
    Specs:
    L2014 Mac mini macOS 10.13, iPhone 8+ iOS 11, iPad Pro 1 12.9" iOS 11,  Pencil 1
    Did you look in Settings > Safari > Autofill > Names and Passwords is activated?
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  7. #7

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    Ferraro,
    Yes

  8. #8

    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, USA
    Posts
    4,295
    Specs:
    L2014 Mac mini macOS 10.13, iPhone 8+ iOS 11, iPad Pro 1 12.9" iOS 11,  Pencil 1
    And you are only using one single Apple ID across all devices?
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  9. #9

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    ferrarr
    Sorry for the typo.
    Yes, all using same Apple ID.
    When I received your request for info, I was in the middle of editing a few obvious errors in the list of passwords in Safari prefs. I then checked to see if these corrections showed on my iPad-they did. I then tried a few websites on iPad that needed passwords and it now worked, even on sites I had not edited. As I first typed this current response, I found, however, that auto fill in for Mac-forums did not work. After pressing the post button, I get error message that I needed to refresh the page and in doing so, I found the post was gone and I had to sign back in, but now the auto fill worked. I am at a complete loss as to why it seemed to take so long for the auto fill to take hold, but at least it is, which is the important thing.

  10. #10

    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    4,157
    Specs:
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS Sierra 10.12.6
    So, we're all happy bunnies? Everything now working, I presume?

    There is no law on earth that can explain these glitches; but turning off/on or signing off/in does do the trick in many cases.

    I see these gestures as "resetting" the system. Not a technical explanation, but one most of us can understand

    Ian
    Ian

  11. #11

    tape's Avatar
    Member Since
    Nov 14, 2010
    Location
    Orange County, NY
    Posts
    336
    Specs:
    iMac-21.5"(2017):OS HighSierra:10.13.5 IOS11.4 iPhone 8+ iPadpro v2
    Ian,
    Yes - it does appear that all is working (although I am a little bit skeptical as logging on to Mac-Forums this morning on my ipad did not present me the opportunity to automatically fill in key words to log in as it did last night) and I will just accept the situation as the way it is. Thanks for your help and comments.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No Posting w/iOS Devices?
    By MacShane in forum iOS and Apps
    Replies: 6
    Last Post: 09-27-2013, 02:02 PM
  2. Homesharing not working between iOS devices and iMac
    By svrasmu in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 11-29-2011, 01:58 PM
  3. how many ios devices on one account?
    By RustProofCorn in forum iOS and Apps
    Replies: 1
    Last Post: 10-16-2011, 03:12 AM
  4. Apple purported working on curved-glass iOS devices for 2012
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 0
    Last Post: 09-26-2011, 08:34 AM
  5. Restricting iOS devices
    By praemus in forum iOS Development
    Replies: 1
    Last Post: 04-09-2011, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •