Results 1 to 7 of 7
  1. #1
    wireless printinf problem...

    Member Since
    Jul 14, 2006
    Posts
    28
    Specs:
    iMac 20" Core 2 Duo - 2.16 GHz - 2Gb RAM - 256 Mb Graphics
    Exclamation wireless printinf problem...
    I have a dell computer hooked up to a dsl modem which sends wireless internet to my imac. Connected to the dell computer is a dell photo all-in-one printer. I am not have good luck with wireless printing. I went into system prefs and it found the printer and everything, but when I go to print something no box pops up and nothing prints. I've heard you need certain drivers for some printers, but I haven't been able to find any drivers for a dell printer anywhere. Does anyone know what I should do?

  2. #2
    wireless printinf problem...
    mac57's Avatar
    Member Since
    Apr 29, 2006
    Location
    St. Somewhere
    Posts
    4,560
    Specs:
    iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM
    Could this be a firewall issue? Most DSL modem/router boxes contain a firewall, and it may be blocking your dialogs? I know that this is a long shot, but perhaps you could try turning off the firewall on the modem/router and try again. If it works, you know you have found your culprit.

    You present this as a wireless printing problem - does this mean that it works if you connect the iMac to the DSL modem/router directly via cable vs. wireless?
    My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
    My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
    My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
    I was on the Mac-Forums honor roll for September 2007

  3. #3
    wireless printinf problem...

    Member Since
    Apr 25, 2003
    Location
    The home of the free and the land that did for Braveheart.
    Posts
    1,301
    Specs:
    24"iMac, 15"MB-Pro, MacBook, G4 iMac, PM G5 2x2Ghz, G4 iBook & Some PCs
    Quote Originally Posted by kman118 View Post
    I have a dell computer hooked up to a dsl modem which sends wireless internet to my imac. Connected to the dell computer is a dell photo all-in-one printer. I am not have good luck with wireless printing. I went into system prefs and it found the printer and everything, but when I go to print something no box pops up and nothing prints. I've heard you need certain drivers for some printers, but I haven't been able to find any drivers for a dell printer anywhere. Does anyone know what I should do?
    What exactly do you mean by "found the printer"?

    If the printer is conected to the Dull then you will need to set the Dull up to be a print server, that sort of thing is gonna get complicated real quick.

    How is the printer connected up, via USB? What OS are you running on the Dull, Xp, Win98, Linux?

    Far too many variables here to really be of much help I'm afraid.

    Amen-Moses

  4. #4
    wireless printinf problem...

    Member Since
    Jul 14, 2006
    Posts
    28
    Specs:
    iMac 20" Core 2 Duo - 2.16 GHz - 2Gb RAM - 256 Mb Graphics
    Ok, well I can't connect the two computers by a cable, ones upstairs and ones downstairs, and I don't have a choice to move the printer either.

    What I meant by it found the printer is when I went into system prefs/ print and fax and went to add a printer, I clicked "More Printers..." and the dell computer showed up, I clicked that and it told me to put in a password, then the printer came up, "Dell Photo AIO Printer 955" so I clicked that and it showed up in the main printer configuration box.

    I have the printer connected to the dell set to sharing over the server.

    The printer is connected to the dell by a usb, and the dell is running xp.

    I will try to turn off the firewall and see what happens.

  5. #5
    wireless printinf problem...
    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,757
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Your issue is likely related to the driver that the Mac chose to use for your Dell AIO. In all likelihood, Mac OS chose to use a Generic Postscript driver and that's probably not going to work.

    Dell doesn't provide driver support for Mac OS. That's not necessarily the end of the road for your Dell printer since it is very likely just a rebadged Lexmark. The trick is to figure out what Lexmark model shares the guts with your Dell. Once you figure that out, you can just go to Lexmark's site and download the appropriate driver.

    That said, if the Lexmark driver is not "network aware" (i.e. it just assumes that you have the printer connected via USB, you'll need to find a generic Gimp-print driver that will work with it.

    That raises the degree of difficulty in getting it to work to another order of magnitude.

    I'll do a little research and let you know what I find out.

    My advice is that if you need a network printer, buy a new one that has built-in network support and a Mac driver.

  6. #6
    wireless printinf problem...
    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,757
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    BTW, is the model number really 955? I can't seem to find any reference information on that particular machine.

  7. #7
    wireless printinf problem...

    Member Since
    Jul 14, 2006
    Posts
    28
    Specs:
    iMac 20" Core 2 Duo - 2.16 GHz - 2Gb RAM - 256 Mb Graphics
    Oh sorry, yeah it's actually 922, not 955...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wireless N problem
    By silvine in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 02-01-2011, 05:47 AM
  2. Old G3 Wireless problem ..?!?!?!?!?
    By TattooedMac in forum Apple Desktops
    Replies: 28
    Last Post: 01-11-2011, 03:31 PM
  3. Acer win7 wireless problem (kinda linked to my mac wireless too)
    By Jonik in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 11-12-2010, 10:05 AM
  4. Problem with Kensington Wireless Presenter (USB wireless Remote Control)
    By Noriker in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 05-18-2009, 08:32 PM
  5. wireless problem
    By jkbuchanan in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 05-17-2008, 12:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •