Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Louise McSharry
    Guest
    Question Help Please! Airport showing full signal but no internet connection.
    Please please please help, I am tearing my bloody hair out here. I have used my macbook several times with many different wireless networks, and most of the time it works fine.

    However, twice, I have had problems with 2 seperate wireless networks. Basically, airport connects and shows full signal, but then when I try to open safari it says there is no internet connection.

    I have looked and looked and looked for a solution but no joy. Has anyone had the same problem? Any advice? I have connected to these specific networks before without problems, and the PCs in the house are having no trouble so it is definitely functioning.

    I really would be grateful if someone could help. :bomb:

  2. #2
    Help Please!  Airport showing full signal but no internet connection.
    kgeier82's Avatar
    Member Since
    Dec 01, 2006
    Posts
    1,495
    Specs:
    MBP 2.4/2GB/200HD/256 8600gt
    are they your personal networks? im wondering because maybe some mac filtering is going on. i did that, and mine would show connected, but as you say, "no internet connection detected".

  3. #3
    Help Please!  Airport showing full signal but no internet connection.
    Daddy Elmis's Avatar
    Member Since
    Mar 28, 2006
    Posts
    390
    I had this problem with an iMac (intel) and an airport (extreme base with an express for range/iTunes). My issue was I'm using DSL with PPPoE, and my modem/router (Westell 6100) was configured as a router with PPPoE handling, as was my Airport Extreme . . . I think they fought over who was maintaining the PPPoE connection. I reset my Westell to "dumb modem" mode and let the Airport maintain the PPPoE and that seems to have solved the problem.

  4. #4
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 12, 2011
    Posts
    4
    Exclamation Full Power Wireless Used Daily Since Jan1- No Connection After Unplgd
    I've been using my connection since Jan1, cleaned up yesterday, unplugging and replacing every part properly. Now internet shows up as full power- however my computer says "No Internet Connection". Restarted everything several times. Network Diagnosis doesnt help. Any clues?

  5. #5
    Help Please!  Airport showing full signal but no internet connection.
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,033
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    Go into System Preferences > Network > Advanced > Airport and delete the account by highlighting and using the little (-) buttonj and set up a new WPA2 Personal account and password.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  6. #6
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 07, 2011
    Posts
    8
    This sounds precisely like the problem I posted about elsewhere here. For me it's an mDNSResponder issue. For whatever reason my Wi-Fi connection will work for anywhere between 5 minutes and a few hours with no problem whatsoever. Then.. all DNS requests get ignored (or dropped, or sent to purgatory.. I'm not sure) but, accordingly, I'm not able to connect to the internet.

    When this happens.. try clicking your Wi-Fi icon and "Turn AirPort Off" and then turn it back on again after a few seconds and reconnect. I've found that often resets the issue and you're again good for 5 minutes to a few hours. But just a band-aid.

    I'm sorry to say that, after about a year of research into this, I've only found 2 solutions that can guarantee me a stable connection:

    1) Reboot the machine when it happens. Yes.. every single time.
    2) Windows XP.

  7. #7
    Help Please!  Airport showing full signal but no internet connection.
    osxx's Avatar
    Member Since
    Jan 19, 2008
    Location
    houston texas
    Posts
    4,695
    Specs:
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    To better diagnose some of these things posting your internet service provider ,modem/router make and model along with model and year of Mac along with what OS. Also if wireless state if a,b,g or n and 2.4GHz or 5GHz. Thanks.

  8. #8
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 07, 2011
    Posts
    8
    ISP: RoadRunner (Time Warner)
    Modem: Cisco DPC2100R2
    Router: Both Medialink Wireless-N Router MWN-WAPR150N and D-Link DIR-615
    Mac: 13" Macbook Early 2009
    OS(s): Both Leopard and Snow Leopard
    Wireless: In both g and n (mixed or exclusive with either); 2.4 GHz

  9. #9
    Help Please!  Airport showing full signal but no internet connection.
    osxx's Avatar
    Member Since
    Jan 19, 2008
    Location
    houston texas
    Posts
    4,695
    Specs:
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    Quote Originally Posted by squallen View Post
    ISP: RoadRunner (Time Warner)
    Modem: Cisco DPC2100R2
    Router: Both Medialink Wireless-N Router MWN-WAPR150N and D-Link DIR-615
    Mac: 13" Macbook Early 2009
    OS(s): Both Leopard and Snow Leopard
    Wireless: In both g and n (mixed or exclusive with either); 2.4 GHz
    How are you routing from the Cisco to _______ to ________ and if one is N and
    the other G are they on different channels ? Make sure your not double NATing.

  10. #10
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 12, 2011
    Posts
    4
    Exclamation Did all that..
    I have deleted the network, re-added with correct password- however will not connect- "Airport does not have an ip address and will not connect to the internet" is this obvious? everything has been rebooted several times

  11. #11
    Help Please!  Airport showing full signal but no internet connection.
    osxx's Avatar
    Member Since
    Jan 19, 2008
    Location
    houston texas
    Posts
    4,695
    Specs:
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    Quote Originally Posted by MsLin View Post
    I have deleted the network, re-added with correct password- however will not connect- "Airport does not have an ip address and will not connect to the internet" is this obvious? everything has been rebooted several times
    In the Airport do you have IPv4 set to DHCP also did you click on renew lease?

  12. #12
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 12, 2011
    Posts
    4
    Yes and Yes, "THe Airport has no IP Address and cannot connect to the internet" :-(

  13. #13
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 07, 2011
    Posts
    8
    Quote Originally Posted by osxx View Post
    How are you routing from the Cisco to _______ to ________ and if one is N and
    the other G are they on different channels ? Make sure your not double NATing.
    I should rephrase my earlier post:

    I've had this problem with both routers individually. I've tried multiple solutions with both of these routers to no avail. Same with the OS.

  14. #14
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 12, 2011
    Posts
    4
    Exclamation
    I have restarted computer and wireless router- turned off airport, deleted networks, re-added networks using proper password. Full Power, renewed lease, IPv4 is using DHCP. Been Using for 4 months no problems- unplugged cable for 20 minutes while cleaning, roomates still use wireless with no problems- only my computer.

    First said "Airport has no IP address and cannot connect" now says "Airport has self-assigned IP address ______ and will not be able to connect to the internet."

    Please help I just want to understand!

  15. #15
    Help Please!  Airport showing full signal but no internet connection.

    Member Since
    May 07, 2011
    Posts
    8
    Quote Originally Posted by MsLin View Post
    I have restarted computer and wireless router- turned off airport, deleted networks, re-added networks using proper password. Full Power, renewed lease, IPv4 is using DHCP. Been Using for 4 months no problems- unplugged cable for 20 minutes while cleaning, roomates still use wireless with no problems- only my computer.

    First said "Airport has no IP address and cannot connect" now says "Airport has self-assigned IP address ______ and will not be able to connect to the internet."

    Please help I just want to understand!
    Wait.. what 'cable'? If you're using Wi-Fi there shouldn't be any cables.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mac book pro: showing full wifi connection but internet not working
    By flytox in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 03-22-2012, 12:26 AM
  2. "No Internet Connection" - despite Airport showing full connectivity
    By fraggle_rocker in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 03-03-2012, 01:58 PM
  3. Airport connected, full signal, suddenly no internet!?!? :(
    By conchshell123 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 12-06-2010, 08:59 PM
  4. Airport shows full connection, but can't connect to internet
    By millerem in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 09-03-2010, 10:00 AM
  5. Network Problem; Internet Connect says full signal but no connection
    By shotdsherrif in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 10-24-2008, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •