Results 1 to 2 of 2
  1. #1

    Member Since
    Mar 02, 2012
    AirPort is not working on iBook G3
    Hello. I have tried everything. We acquired the iBook G3 Mac OS X (version 10.4.11) from a friend. It has 500 MHz Processor and 384 MB SDRAM. There is an AirPort card in it. It worked a year ago (connected to our network). We moved and have a different provider and different router now. All our laptops (windows) work fine as well as my kids ipods. Someone came over and changed the specs on the router because that was supposedly the problem. Then changed the security to WPA Personal because WEP was not working. It worked (for a few hours until I closed the lid and restarted it). No matter what I do I cannot get it to connect or find our network. I changed it back to WEP because one forum said the older books cannot read WPA for some reason (then I just read the complete opposite). I then took the AirPort card out and hooked up or wifi usb to the outside. It worked last night for my daughter online. Then today it lost the network again and I can't fix it. So I once again took the wifi out and put the AirPort back in. I have gone everywhere and done everything I could possibly think of and still nothing...many hours later and I am so frustrated!!!! If anybody could PLEASE help me on this I would so greatly appreciate it!

  2. #2

    hugtheslug's Avatar
    Member Since
    Feb 19, 2008
    Kent, UK
    11" MacBook Air / Unibody MacBook / iMac i3 21.5" / iPhone 6

    Yes it's true, older Airport cards will only work with a maximum of WEP security.
    I would firstly shut the iBook down completely, then reset the security on the router to WEP, with a strong password, and restart the router.
    Lastly, start the iBook up once more and see if you can get a connection with the new settings.

    When I had an iBook G3 it was restarting the router then the Mac that finally got things connecting, and after that things were fine.

    Hope this helps,


    A little knowledge is a dangerous thing.
    Warning - this user has only a little knowledge

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport express wireless extending airport Extreme not working out.. help?
    By Hann in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-21-2013, 12:25 PM
  2. Airport Extreme -> Airport Express via Cat6 not working?
    By ltdrebin in forum Internet, Networking, and Wireless
    Replies: 14
    Last Post: 08-24-2011, 03:43 AM
  3. Airport Wireless Internet Not Working on iBook G4 - Airport
    By Kimiko in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 10-05-2008, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts