Results 1 to 8 of 8
  1. #1
    New iMac keeps loosing Internet Connection

    Member Since
    Feb 13, 2007
    Location
    Worthing, West Sussex, UK
    Posts
    212
    Specs:
    27" iMac 3.1Ghz 16GB RAM, 1TB HD. iPhone 4.
    Question New iMac keeps loosing Internet Connection
    Bit of an odd one this which has got me stumped and is very annoying.

    Two days ago I bought a brand new 27" iMac to replace my older 2006 model iMac. I also have a 9 month old MacBook Pro and iPhone 4 and an iPhone 3G.

    The old iMac, MBP and both iPhones work perfectly all the time. However the new iMac keeps loosing the Internet connection. Sometimes it will last for an hour or more, othertimes it will last only 20 minutes. The fix is always the same, simply turn off the wi-fi on the iMac and turn it back on again.

    All the computers connect to my router over wi-fi (which was set to mixed wireless G and N but I've also tried setting it to Wirless N only but it made no difference). The new iMac never looses the wi-fi connection, I can still log into the router over wi-fi even when it looses the Internet, but it keeps loosing access to the Internet.

    The router itself is only 3 weeks old as the old one died and non of the other Macs or iPhones have any problems with it, in fact this rotuer seems much better than the old one. The router is a BELKIN N300 Wireless Modem Router

    The only difference between both my other Macs and the new iMac is that the other Macs are running Snow Leopard whilst the new iMac is running Lion.

    Anyone have any ideas how to fix this because it's annoying as **** and makes downloading large files or streaming near impossible!

  2. #2
    New iMac keeps loosing Internet Connection

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    My similar frustrating experiences revolved around choosing the correct band frequency (once I had upgraded from an old Belkin 54G to a Belkin N600DB.)

    Force your iMac to join the 5gHz band and let everything else default to the 2.4gHz and you should see an improvement.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

  3. #3
    New iMac keeps loosing Internet Connection

    Member Since
    Feb 13, 2007
    Location
    Worthing, West Sussex, UK
    Posts
    212
    Specs:
    27" iMac 3.1Ghz 16GB RAM, 1TB HD. iPhone 4.
    I'll try that tonight when I get home but I'm not sure that this is the problem. The iMac is always connected to the router with a strong signal strength as the router is only 3 meters from the iMac.

    When the Internet drops on the iMac I can still log into the router via the browser on the iMac over Wi-Fi so the Wi-Fi connection is working and the router says that it is connected to the Internet and all other devices can access the Internet. It's just that for some reason this new iMac can't

  4. #4
    New iMac keeps loosing Internet Connection

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    Hi,

    I was just going to suggest giving it a try anyway but you wouldn't be able to because your router is not dual band.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

  5. #5
    New iMac keeps loosing Internet Connection

    Member Since
    Feb 13, 2007
    Location
    Worthing, West Sussex, UK
    Posts
    212
    Specs:
    27" iMac 3.1Ghz 16GB RAM, 1TB HD. iPhone 4.
    Quote Originally Posted by pendlewitch View Post
    Hi,

    I was just going to suggest giving it a try anyway but you wouldn't be able to because your router is not dual band.

    Ahh yes, good point. Hmm. I guess I could try using a CAT5 cable to connect the iMac to the router than at least it could rule out Wi-Fi and perhaps point the finger at TCP/IP or DHCP

  6. #6
    New iMac keeps loosing Internet Connection

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    Yes absolutely try that.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

  7. #7
    New iMac keeps loosing Internet Connection

    Member Since
    Feb 19, 2012
    Posts
    2
    new iMac not connecting to wi fi
    Well we bought a new iMac in November 2012, it never worked the way it was supposed to. Initially we thought we had fixed the problem with it not staying connected to the wireless internet by changing our router as directed by apple. We changed it from a WPLN to WAP, then it seemed ok when I checked it for the next day. After that my kids were the only ones using it for the next 2 months or so. We moved it downstairs and put it in my room as my iMac. I realized very fast it had the same issue and wasn't fixed. We called to make sure our router wasn't the issue. It wasn't so we called Apple. After 2 hours of them trying to fix the issue they could not. They told us in the end it is a software issue that they are having issues with. That they have people working on it now. We have had this issue for a total of 3 and 1/2 months though! I will be insisting that they give me a new iMac in a month if they cannot make a software patch for this issue that they are fully aware of.Hope this helps, maybe you should make your call and see what you can find out. In my opinion it should have been fixed long ago, and if not issued a recall.

  8. #8
    New iMac keeps loosing Internet Connection

    Member Since
    Feb 19, 2012
    Posts
    2
    imac not staying connected to wifi
    Selina;1371740]Well we bought a new iMac in November 2012, it never worked the way it was supposed to. Initially we thought we had fixed the problem with it not staying connected to the wireless internet by changing our router as directed by apple. We changed it from a WPLN to WAP, then it seemed ok when I checked it for the next day. After that my kids were the only ones using it for the next 2 months or so. We moved it downstairs and put it in my room as my iMac. I realized very fast it had the same issue and wasn't fixed. We called to make sure our router wasn't the issue. It wasn't so we called Apple. After 2 hours of them trying to fix the issue they could not. They told us in the end it is a software issue that they are having issues with. That they have people working on it now. We have had this issue for a total of 3 and 1/2 months though! I will be insisting that they give me a new iMac in a month if they cannot make a software patch for this issue that they are fully aware of.Hope this helps, maybe you should make your call and see what you can find out. In my opinion it should have been fixed long ago, and if not issued a recall.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Losing Internet Connection
    By EdK in forum OS X - Operating System
    Replies: 2
    Last Post: 08-16-2015, 05:25 PM
  2. loosing wifi connection
    By Loki-sam in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 06-16-2013, 08:25 AM
  3. Loosing internet connection
    By mrotsliah in forum OS X - Operating System
    Replies: 1
    Last Post: 01-14-2011, 05:08 PM
  4. Printer on XP box keep loosing WiFi connection
    By MilenkoD in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 10-09-2009, 01:03 PM
  5. Loosing network connection at startup
    By sebb2004 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 01-30-2005, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •