Hello!

So, I've been having this strange issue with my airport since last night. I've read up on some of the issues and I've tried a bunch of fixes, but nothing seems to work.

I'm using a new macbook I bought in January, running OS X 10.6.2

Last night after my macbook goes to sleep, I wake it back up and find that for some reason, I cannot connect to the internet. My airport icon at the top right of the screen has a little exclamation mark on it, and I go under system diagnostics to try and fix it. I've been using the same router for the last two months, and haven't had it crap out on me, and I didn't download anything new, so I don't know exactly what caused it to stop working. Also, my girlfriend was able to connect to it no problem on her PC, so I know it's a problem with my airport, and not the router.

On top of that strangeness, I can actually connect to ANY other wifi service I find (which is how I'm actually posting this). On top of that, if I take the cable and connect it to the computer, I can use the internet fine (but cables are lame and I don't want to do that).

I've tried deleting all my networks saved under system preferences, but that didn't work. I've rebooted, turned airport on and off, still nothing.

I went under system diagnostics to try and fix it. I follow the instructions (I use DHCP to connect), turn the router on and off, and on the side I get green lights under Airport, Airport settings and ISP, but I get a yellow light under Network Settings. So I open up network settings and I have a yellow light beside airport and under it it says "Self-Assaigned IP," which makes no sense because under TCP/IP I have "Configure IP" set to "using DHCP."

I have the latest updates and everything, so I have no idea what caused this mess. Anyone have any ideas?