My direct LAN ethernet connection has decided to spontaneously stop working.

My situation is macbook pro running wired connection to a tower running Ubuntu.

I have been having no problems since I first started this pairing, but recently it has decided to not work. When I hit Apple + K (connect to server) it gives me the error warning:

"Connection Failed

There was an error connecting to the server "192.168.2.100". Check the server name or IP address, and then try again.

If you are unable to resolve the problem contact your system admin."


I have done a ping of the aformentioned IP via disk utility and am getting this response:

Ping has started…

ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
ping: sendto: Cannot allocate memory
PING 192.168.2.100 (192.168.2.100): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8

--- 192.168.2.100 ping statistics ---
10 packets transmitted, 0 packets received, 100.0% packet loss


I've done a little bit of background search on this. And have done these options, but none are working (I got this advice from another thread):

applejack AUTO

Then let it do all 5 of it's things.

At least it'll eliminate some questions if it doesn't fix it.

The 5 things it does are...


Corrected any Disk problems.
Repaired Permissions.
Cleared out Cache Files.

Tried dragging these files to the Desktop & Reboot...

/Users/nnnn/Library/Preferences/com.apple.internetconnect.plist

/Library/Preferences/SystemConfiguration/preferences.plist

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist


Something that is a little strange is that the file connect.plist frequently turns up in /Library/Preferences (Corrupt). Don't know if this has anything to do with it.

Any help would be appreciated. I'm assuming this is a mac problem, not an ubuntu problem, as Ubuntu seems to be running ok when I run diagnostics.

Thanks,
knockturne