Results 1 to 4 of 4
  1. #1
    Wireless fine on MacBook but not on iMac

    Member Since
    May 23, 2007
    Posts
    6
    Wireless fine on MacBook but not on iMac
    I have a MacBook & a new iMac. The MacBook's wireless works perfectly at my house - always a high signal, lightning fast, no problems whatsoever.

    But, my iMac won't stay connected! I had this same problem at my office with another router, so I know it's not a router problem. Laptop was fine, iMac not so much.

    The network is showing up in the network preferences, and it does connect, but the signal is really weak (one or two bars compared with full signal on my MacBook).

    Not sure if this is where the problem lies, but when I click on the wireless icon on my MacBook, it says "Airport: On". On my iMac, I click the icon and it says "Airport: Scanning...". I have no clue why it's doing this and it's starting to get REALLY frustrating! Can anyone help???

  2. #2
    Wireless fine on MacBook but not on iMac
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,479
    Specs:
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    An iMac G5 is an older computer. It's not new. Are you talking about a new Intel iMac or an older G5 iMac? Very different machines. A G5 is a Power PC CPU and will not run any X86 OS.

  3. #3
    Wireless fine on MacBook but not on iMac

    Member Since
    May 23, 2007
    Posts
    6
    Sorry - it's a new iMac - 2.66GHz Intel Core 2 Duo.

  4. #4
    Wireless fine on MacBook but not on iMac
    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,291
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Think i would be taking it back while it is under warranty, my 2.2 MBP has same indications as 2.4 iMac when on LAN

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling 169 address on wireless but wired is fine
    By vadentech in forum OS X - Operating System
    Replies: 5
    Last Post: 11-01-2013, 02:45 PM
  2. Replies: 0
    Last Post: 05-16-2011, 01:15 PM
  3. wireless mice work poorly, wired fine
    By KeithF40 in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 09-19-2010, 12:33 AM
  4. MacBook connects to wireless network but NOT Internet, but iPod is fine
    By jasetheace in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 07-02-2008, 07:19 PM
  5. Wireless works fine, ethernet connection doesn't
    By gipollard in forum Internet, Networking, and Wireless
    Replies: 8
    Last Post: 04-23-2008, 11:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •