Server: Windows 2000 Server SP4
Mac: Mac OS X (10.3.7)

This problem is being replicated in two different working environments.

I am connecting about 6 Macs to a Windows 2000 Server via SMB. I was originally working over AFP but decided to change to SMB for performance and reliability issues with AFP. Everyone I talk to seemed to suggest to change to SMB as it was faster and more reliable.

Our users use Quark, Photoshop and Illustrator. They work off the server in general as they swap jobs, and one person could be working on a job in the morning and someone else could be working on the same job in the afternoon. This never caused a problem when we connected via AFP but suddenly I am having some issues when connecting over SMB.

“User A” opens a file in Quark, makes a change, saves the file and quits Quark. If someone else then opens the file, makes a change and tries to save the file, it does not overwrite the original file. Instead it creates a QXP-04352345.qxp file (where the numbers are random).
“User A” opens a file in Photoshop or Illustrator, makes a change, saves the file and quits the Application. If someone else then opens the file, makes a change and tries to save the file, it says that the file is already in use.

These two errors are definitely linked and I have sort of found out why.

When we connect over SMB, on a Mac you cannot see these hidden ._filename.ext files. I can see them on the Server without any problem.
If I now go to the Server and look under Computer Management -> Shared Folders -> Open Files, I can see these ._filname.ext files open to “User 1”.
I have tried restarting his machine but as soon as he logs on again, the file is in use.
I have manually closed the ._ file from the server and it will then work.

During the day, people obviously work on quite a few files and this leaves a lot of these ._ files open (even overnight).
The only way that I can see to close all these files is when everyone shuts down overnight.

This is fine but doesn’t seem to sort my problem for people sharing files during the day.

Please don’t give me any information from Adobe or Quark that say they suggest working locally because it is not a Quark or Adobe problem. It is either a Server configuration issue or a Mac OSX SMB issue.

Has anyone come across this problem before and does anybody know a workaround?

If you need more information please let me know as I need to get this sorted asap.

Thanks