Results 1 to 4 of 4

Thread: Canon SD990

  1. #1
    Canon SD990

    Member Since
    Oct 25, 2010
    Posts
    2
    Canon SD990
    Hi there, I just got an imac computer this weekend and I'm having trouble connecting it using the canon software. I spent lots of time this weekend searching the web and was able to get it to recognize using iphoto. I would really like to use the canon software since I'm used to it but can not get the image program to recognize the camera. Any ideas? Again I'm brand new to the Mac world so please don't assume I know anything Thanks.

  2. #2
    Canon SD990
    SweetCosmicPope's Avatar
    Member Since
    Dec 16, 2009
    Location
    Baytown, Tx
    Posts
    373
    Specs:
    Late 2009 Macbook Pro 2.26, 160gb HD, 2gb RAM, OSX 10.6; Emac 1.42ghz 80gb HD 2gb RAM OSX 10.5
    Doesn't sound like it's an issue with the camera or even with the mac, since it loads in iPhoto.

    You say that the image program won't recognize the camera. Am I to take it then that there is a mac version and it's installed? If so, it sounds like there may be an issue with the software, possibly.

    What software does it use?
    "That's Peter Graves scat! I'd know it anywhere!"

  3. #3
    Canon SD990

    Member Since
    Oct 25, 2010
    Posts
    2
    I still had the disc that came with the camera, which I installed on the mac. So the software is the camera software. I even tried loading the newest version from the canon site which didn't work either. When the canon software opens it pulls up the image capture program and that shows no camera.

  4. #4
    Canon SD990
    SweetCosmicPope's Avatar
    Member Since
    Dec 16, 2009
    Location
    Baytown, Tx
    Posts
    373
    Specs:
    Late 2009 Macbook Pro 2.26, 160gb HD, 2gb RAM, OSX 10.6; Emac 1.42ghz 80gb HD 2gb RAM OSX 10.5
    Man. Did a little googling. Can't find anything recent. They had some issues in 2006 with the software, apparently, but this is a newer camera than that...

    I'd tell you to just use iPhoto, but I know that doesn't exactly answer your question. Wish I could be of more help, but I'm not familiar with the software.
    "That's Peter Graves scat! I'd know it anywhere!"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Canon Navigator for Canon MP560 stopped working
    By radiomother in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 02-05-2013, 07:15 PM
  2. Replies: 2
    Last Post: 09-10-2009, 06:00 PM
  3. The new Canon G7???
    By ByzantineRemnant in forum Images, Graphic Design, and Digital Photography
    Replies: 11
    Last Post: 11-11-2006, 01:58 AM
  4. Print Quality of the Canon IP3000, relative to other Canon models??
    By VakeJ in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 03-06-2005, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •