Hi all, I am new to macs, having recently sprung for a mac pro.
The problem I'm having is with photoshop elements on the mac.
I had PSE 5.0 on my PC, so when I got the mac I loaded it on there, but many of the features didn't work, yesterday I tried downloading the PSE 6.0 for mac trial version, it downloaded but I haven't been able to open it. An icon appeared on the desktop with options for language when it is opened, when I click on the english version I get a list of 4 files/folders named Bootstrapper, payloads,resources and setup, when I click on setup I get an error message saying: Java Script Alert- critical errors were found in setup- incompatible payloads already installed- please see the setup log file for details:

I deleted the PSE 5.0 but that made no difference, any advice on what to do next?
my OS is version 10.5.6
thanks for any help