Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Web Design and Hosting (http://www.mac-forums.com/forums/web-design-hosting/)
-   -   iWeb crashes on loading. (http://www.mac-forums.com/forums/web-design-hosting/52343-iweb-crashes-loading.html)

GRPGM 02-01-2007 02:15 AM

iWeb crashes on loading.
 
I'm not sure where to ask this, but just tonight, after loading and using it earlier today, iWeb refuses to boot up.

The symbol bounces on the dock, then vanishes and an error message appears. Not sure what to do about it . . . any suggestions?

NanoBite 02-01-2007 03:37 AM

G'day GRPGM,

I guess you're going to have to offer some further information as to your Mac and it's specs, what the error message says.

Have you tried launching iWeb from the Applications folder?

Try removing the pref file for iWeb:

Navigate to YourUserAccount>Library>Preferences and delete the following:

com.apple.iWeb.plist

Restart your Mac and see if this helps....

GRPGM 02-01-2007 08:22 AM

I'm using a 20" iMac, 2.16 dual core 2, 2 gb RAM, 250gb hd, X1600 ATI Radeon . . .

iPhoto and all the other iLife apps are working great, I was having a ton of fun making a video with 'em, but iWeb has just completely stopped trying. I did delete the preferences file as you suggested, and my .Mac trial account hasn't expired . . . so I'm not really sure where the problem is. =/

NanoBite 02-01-2007 09:01 AM

Do you have a maintenance app like MacJanitor or OnyX that you can fire up to clean out all the caches?

Repair permissions and verify your HD too as a good housekeeping measure.

If this doesn't work you can reinstall iWeb from the dvd that came with your iMac:

http://docs.info.apple.com/article.html?artnum=301408

mraya 02-01-2007 01:40 PM

Your .Mac account has nothing todo with it, it doesn't affect iWeb in that way. Usually if iWeb refuses i'm my case it has to 2 things:

- The TemplatesInfo.plist file is corrupt/it's been corrupted. If you know what i'm talking about, you probably have been playing with it, review it for errors or replace it with a backup copy. If you don't know what i'm talking about it probably isn't the problem. In any case, reinstalling iWeb will solve this problem.

- The Domain file has been corrupted. One of the problems (IMHO) ofiWeb is that it keeps all your pages and sites in one big XML file, if there is a problem saving one of your pages it can corrupt this file, not allowing iWeb to load, this has happened to me twice, but this isn't common. This file is located under:
User>Library>Application Support>iWeb>Domain

I would recommend you to reinstall iWeb, this won't destroy anything you have been working on and is the best way to solve the problem. If you still have a problem, depending on how much you have done with iWeb, i would recommend you to delete the Domain file (see path above), reinstall and start again.
I have had this 2 problems and that is how i solved, still it can be something else.

GRPGM 02-01-2007 05:29 PM

Thanks a lot guys. I did a re-install like ya'll suggested and everything seems to be working out great again, but I've recorded all your suggestions in case I ever have a problem again.

eddy7496 10-16-2007 06:04 PM

I have had my Domain file go corrupt....cried....and have started over...I still have that corrupted file as I had typed up some stories which were saved on some of the pages in that domain file...Is there any way I can view the pages as html documents when I right click on the broken domain file and click "Show Package Contents"...?

Well, thanks...

John Edmunds
www.DeserteDNJ.com


All times are GMT -4. The time now is 10:22 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.