New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Web Design and Hosting Creating sites, scripting, and hosting discussions.

VirtualHost Help


Post Reply New Thread Subscribe

 
Thread Tools
MrGecko

 
MrGecko's Avatar
 
Member Since: Oct 02, 2006
Posts: 65
MrGecko is on a distinguished road
Mac Specs: se30 16MHZ 1.44MBHD Performa 630 CD 33MHZ 250MBHD iMac G3 333MHZ 60GBHD iMac G4 800MHZ 250GBHD

MrGecko is offline
My VirtualHost is not working can any one help me heres a link to my settings
QUOTE Thanks
xstep

 
xstep's Avatar
 
Member Since: Jun 25, 2005
Location: On the road
Posts: 3,231
xstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to all
Mac Specs: 2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid

xstep is offline
How is it not working? Is httpd even starting up? When you ask a question you need to give more information then just, 'here is my config file'. Have you tried "apachectl configtest" at the comand line?

My take on the matter is that you need to change "127.0.0.1:80" to an asterist (*). Maybe not for your real localhost. I can only judge from my own virtual config files.
QUOTE Thanks
MrGecko

 
MrGecko's Avatar
 
Member Since: Oct 02, 2006
Posts: 65
MrGecko is on a distinguished road
Mac Specs: se30 16MHZ 1.44MBHD Performa 630 CD 33MHZ 250MBHD iMac G3 333MHZ 60GBHD iMac G4 800MHZ 250GBHD

MrGecko is offline
Quote:
Originally Posted by xstep
How is it not working? Is httpd even starting up? When you ask a question you need to give more information then just, 'here is my config file'. Have you tried "apachectl configtest" at the comand line?

My take on the matter is that you need to change "127.0.0.1:80" to an asterist (*). Maybe not for your real localhost. I can only judge from my own virtual config files.
it starts up but i'm un able to get the site on my other computer
QUOTE Thanks
Grez

 
Member Since: Jul 10, 2006
Posts: 7
Grez is an unknown at this point

Grez is offline
Quote:
Originally Posted by MrGecko
it starts up but i'm un able to get the site on my other computer
You won't be able to get to it as 127.0.0.1 on any computer points to itself. So when you put 127.0.0.1 into your other computer it will try to access itself, and therefore will not connect to the remote machine. Change 127.0.0.1 to the ipaddress of the server on which httpd is running.

Grez..
QUOTE Thanks
TheMonkey
Guest
 
Posts: n/a

I use: http://patrickgibson.com/utilities/virtualhost/

It takes the legwork out of playing around with httpd.conf.
QUOTE Thanks
MrGecko

 
MrGecko's Avatar
 
Member Since: Oct 02, 2006
Posts: 65
MrGecko is on a distinguished road
Mac Specs: se30 16MHZ 1.44MBHD Performa 630 CD 33MHZ 250MBHD iMac G3 333MHZ 60GBHD iMac G4 800MHZ 250GBHD

MrGecko is offline
Quote:
Originally Posted by Grez
You won't be able to get to it as 127.0.0.1 on any computer points to itself. So when you put 127.0.0.1 into your other computer it will try to access itself, and therefore will not connect to the remote machine. Change 127.0.0.1 to the ipaddress of the server on which httpd is running.

Grez..
that dose not work
QUOTE Thanks
MrGecko

 
MrGecko's Avatar
 
Member Since: Oct 02, 2006
Posts: 65
MrGecko is on a distinguished road
Mac Specs: se30 16MHZ 1.44MBHD Performa 630 CD 33MHZ 250MBHD iMac G3 333MHZ 60GBHD iMac G4 800MHZ 250GBHD

MrGecko is offline
Quote:
Originally Posted by TheMonkey
I use: http://patrickgibson.com/utilities/virtualhost/

It takes the legwork out of playing around with httpd.conf.
i know how to do that with out shell script i use go to in the finder and i type in /etc/httpd
but it is only local it is not world wide
i have tryed the host file in /etc but it is onlt local
QUOTE Thanks
cazabam

 
cazabam's Avatar
 
Member Since: Jun 06, 2006
Posts: 1,153
cazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of light
Mac Specs: MacBook 2.0GHz White, 512MB RAM, 60GB HDD

cazabam is offline
I sounds like your problem is related to two things:

1) Your Apache server is only listening on the loopback interface, and
2) Your other machine is not configured to look to your Apache server for those hostnames

The solution to the first is to get it to listen on all interfaces (*:80). The solution to the second is to edit /etc/hosts on the client machine, or use DNS.
QUOTE Thanks

Post Reply New Thread Subscribe


« Dreamweaver | how do i enable the php mail function »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
apache server (httpd.conf error) oo_mac_oo OS X - Development and Darwin 15 10-09-2003 10:44 AM

All times are GMT -4. The time now is 10:07 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?