New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Web Design and Hosting Creating sites, scripting, and hosting discussions.

Font "tweaks" working in Safari locally, but not working on "live" site


Post Reply New Thread Subscribe

 
Thread Tools
MMM717

 
Member Since: Sep 24, 2013
Posts: 3
MMM717 is on a distinguished road

MMM717 is offline
Hello,

I've been designing a site for a business I've put together that is *sometimes* giving me some issues when displayed in Safari.

My site's various font "tweaks" - font weight (sometimes only on certain words), HTML based italics (using the <em> tags), etc. - are sometimes not working in Safari. When I display the site locally (on a Windows based computer that has Safari) all looks correct, but when viewing it live on the same computer it's missing the adjustments I've made (though it's fine "live" with all other browsers). On my other computer (a Mac), it's OK live. When testing on two other friend's computers (both Macs), all was fine on one, and not on the other.

I'm not sure what's going on here, and I seem to have stumped some others I asked for help on this. I luckily found this forum, since it has a Mac focus (given my issues are with viewing in Safari).

I can give the site to anyone who wishes to take a look and try to help, but I'd need to PM you with the URL. It's still a private site at the time...

Thanks very much in advance...
QUOTE Thanks
MMM717

 
Member Since: Sep 24, 2013
Posts: 3
MMM717 is on a distinguished road

MMM717 is offline
I should add that I've been able to narrow this problem down to Safari version 5. A friend with a pretty new Mac and Safari 6 has everything on the site display as intended, as does my older Mac (which I think is Safari 3). However, my Windows based computer where this is a problem (and only with the "live" version - the local one is fine) is using 5, as is another friend with a Mac who is having the same issues I'm having with the Safari 5/Windows 8 combination.

I'm using @font-face. I've tested in Chrome, Firefox, variants of IE, even Opera, and all is fine. I've read that sometimes the SVG font type can be a problem, but I even tried modifying my code to target Safari 5+ to use the TTF font file instead, and that made no difference in Safari 5 "live". Figuring I may have written my code wrong, I even instead tried removing the code to the SVG file, and the result was the same. I should add that Safari 5 (running the "live" site) IS displaying the intended font, but missing all my adjustments to the basic look (aside from font size). It is the ONLY problematic browser variant I've been able to find.

I've been digging around online and while it seems Safari 5 has caused various font related issues, I can't quite hit on something exactly like the problem as I'm having, nor a fix that works.

Any ideas?
QUOTE Thanks
MMM717

 
Member Since: Sep 24, 2013
Posts: 3
MMM717 is on a distinguished road

MMM717 is offline
Are there any known issues at all re style related coding for Safari version 5 that I could possibly try and apply to my code? I'm digging around online, and anything I've seen and attempted in adjusting my code has made no impact. I realize I'm a beginner at this, but at the same time I'm stumped...
QUOTE Thanks

Post Reply New Thread Subscribe


« Can you write a path in the database field that links to an external file on my mac? | HTML body background-color shows in front of image since iOS 7 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Safari wont access a site buster1 OS X - Apps and Games 4 04-10-2010 02:04 PM
Can't access a web site in Safari nickyr OS X - Operating System 8 09-28-2009 03:19 PM
Dreamweaver help - site not working in Explorer helenhall Web Design and Hosting 2 11-22-2008 02:51 AM
safari acting very strange with my site crackberry Web Design and Hosting 0 02-06-2008 05:05 PM
I can't get to Perez Hilton site from Safari dead of night Switcher Hangout 2 06-20-2007 08:45 AM

All times are GMT -4. The time now is 08:19 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?