Results 1 to 8 of 8

Thread: Safari

  1. #1


    Member Since
    Mar 24, 2013
    Posts
    3
    Angry Safari
    I built and admin a small website for a friend who uses a MAC with os 10.6.8 & Safari 5.1.1.

    Problem: Safari sometimes display the pages in bits and pieces and will not load embedded audio files nor animated cursors.

    I have a few other friends who use MACs and I have had them look at the site and they same the same thing.

    I use a PC w/winXP pro and IE and everything works like it is supposed to..

  2. #2

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,782
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    I removed your email address to prevent spamming.

    It's very possible that the page just doesn't render properly in Safari. However, WebKit is a well designed layout engine and should be able to handle just about anything thrown at it. What is the URL?
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  3. #3

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,935
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Does the site mess up with Firefox or Chrome or Opera on said systems? A site that works in IE might have issues elsewhere as IE has it's one code that works properly only in IE.

    It really depends on how the site was coded.

    Give us a URL so we can test it.

  4. #4


    Member Since
    Mar 24, 2013
    Posts
    3
    Safari
    the site is Thevillageharpist.com

    Please keep in mind, its nothing professional, I just but it together using some hand coding, some Office and some other small programs. Just simple stuff

    I downloaded Safari, and it works fine except the animated cursors (no big deal there), but the audio does not load.

    If I give safari a direct link: thevillageharpist.com/fortunes.mp3, it opens and plays.......

    I have suggested other browsers but really, whats the sense in that, Its only been since she upgraded the Safari browser I think. When I first built the site at ther house, her Mac played everything as it was supposed to excep the animated cursors (again, no big deal there)

  5. #5

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,935
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    The only thing I see is toward the right the part with the trees is broken and starts over again. Will try it in Firefox and Chrome.

    Ok same in all browsers. It's the picture you have as a background. It's not wide enough and is displaying itself over again on the right hand side. If I shrink my browsers window it's great. You can fix that with a statement in HTML or resize the image. Someone else here that knows even more HTML will probably chime in and help.

    It's Not a Safari issue.

    Pardon my wording, not doing too well today!


  6. #6

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,782
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    Quote Originally Posted by 3rdrck View Post
    Please keep in mind, its nothing professional, I just but it together using some hand coding, some Office and some other small programs.
    Office? What did you design in Office that's part of this page?

    Quote Originally Posted by 3rdrck View Post
    I downloaded Safari, and it works fine except the animated cursors (no big deal there), but the audio does not load.

    If I give safari a direct link: thevillageharpist.com/fortunes.mp3, it opens and plays.......

    I have suggested other browsers but really, whats the sense in that, Its only been since she upgraded the Safari browser I think. When I first built the site at ther house, her Mac played everything as it was supposed to excep the animated cursors (again, no big deal there)
    The answer to this one is easy. The tag you used to play the background sound, bgsound, is an IE specific tag and thus, won't work elsewhere (MS is notorious for developing IE specific functionality). Take a look at the more vendor neutral ideas here.

    The trails for the cursor don't work because there's an error in your script (line 104, 'left' is not a property for the object).
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  7. #7

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,935
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    I had a feeling there was some MS Specific commands in there somewhere. I was just noticing the background overlapping.

  8. #8


    Member Since
    Mar 24, 2013
    Posts
    3
    Thank You, I'll check it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to reduce Safari Browser Window when opening up Safari
    By rrbruce49 in forum OS X - Operating System
    Replies: 3
    Last Post: 06-09-2015, 11:15 PM
  2. Safari won't launch: error message 'Safari quit unexpectedly
    By Abbynormal329 in forum OS X - Operating System
    Replies: 9
    Last Post: 03-19-2015, 03:51 PM
  3. Replies: 0
    Last Post: 05-23-2009, 08:35 PM
  4. Replies: 4
    Last Post: 03-22-2008, 12:56 PM
  5. Replies: 1
    Last Post: 01-26-2007, 11:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •