New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Web Design and Hosting Creating sites, scripting, and hosting discussions.

Broken links in iWeb


Post Reply New Thread Subscribe

 
Thread Tools
bolton59

 
Member Since: Mar 09, 2011
Posts: 17
bolton59 is on a distinguished road

bolton59 is offline
I have a couple of broken links on a website, the same link works fine on 3 pages and not on the other 2. I have copied the links from the working pages into the broken ones, but this does not work. I have redone the links and uploaded the site again, but still the 2 broken links remain.
Has anyone any ideas ?
Is there an html editor that I can use to check the code on the broken links ?
Please advise.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,750
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
you can just right-click on the page and view source in a browser

Do you get the same issue when preview on your Mac? or is it just once uploaded?

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
bolton59

 
Member Since: Mar 09, 2011
Posts: 17
bolton59 is on a distinguished road

bolton59 is offline
Quote:
Originally Posted by mrplow View Post
you can just right-click on the page and view source in a browser

Do you get the same issue when preview on your Mac? or is it just once uploaded?
The links are only broken when the site is uploaded, in iWeb they work fine.
QUOTE Thanks
bolton59

 
Member Since: Mar 09, 2011
Posts: 17
bolton59 is on a distinguished road

bolton59 is offline
The links are only broken when the site is uploaded, in iWeb they work fine.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,750
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
And how does the link differ (between working and non-working) when you view the source?

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
bolton59

 
Member Since: Mar 09, 2011
Posts: 17
bolton59 is on a distinguished road

bolton59 is offline
The link appears to be the same in both iWeb and the source, I can't see a difference.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,750
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
It's hard to help without seeing the source link.

But the next things I'd try is typing that link into browser. If it doesn't work remove parts of the path bit by bit until you get to a part that's working, then you'll find the point of failure.

It sounds likes it's a case sensitivity/folder permissions kind of issue if the links look identical

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
bolton59

 
Member Since: Mar 09, 2011
Posts: 17
bolton59 is on a distinguished road

bolton59 is offline
Thanks I'll try that and let you know...
QUOTE Thanks

Post Reply New Thread Subscribe


« Dedicated Web/Email Hosting | FTP help with FileZilla please »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
iweb previous and next functionality broken claireb Web Design and Hosting 0 04-10-2012 04:44 AM
iWeb '08 links don't work in iWeb '09 zwickflicks Web Design and Hosting 0 01-31-2012 04:43 PM
Links in iweb Photo Album Kjune Web Design and Hosting 0 12-11-2009 12:56 PM
iWEB & the mystery of the links thedill Web Design and Hosting 2 08-11-2008 10:59 AM

All times are GMT -4. The time now is 12:26 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?