Results 1 to 6 of 6

Thread: OS X Websharing

  1. #1
    DylanMcDonald
    Guest
    OS X Websharing
    I'm trying to set up a web-site running from my PowerBook. I turned on Personal Web Sharing and the IP it shows to view the website on is my network IP. Is there something I can do so it is viewable on the World Wide Web?

    I have tried forwarding port 80 to my network IP. But when I type in my external IP, it brings me to my Modem Configuration page.

  2. #2

    sarahsboy18's Avatar
    Member Since
    Jan 30, 2005
    Location
    Fort Worth, Texas
    Posts
    1,069
    Specs:
    Mac Pro, 8-Core 2.8Ghz, 10GB RAM, 2x1TB HDDs, iPod U2 Edition
    You will have to setup port forwarding on your modem/router and send port 80 to go to your Powerbook's internal IP. That being said... Most ISPs have rules concerning hosting from your internet connection and you can even get lose your internet service over it. So make sure your ISP allows it in their service terms before setting it up.
    "If you had a friend who was a tightrope walker, and you were walking down a sidewalk, and he fell, that would be completely unacceptable." -Mitch Hedberg

  3. #3


    Member Since
    Oct 01, 2004
    Posts
    3,378
    What kind of modem is it? Do you have a stand alone router, or it it part of the modem?

  4. #4
    DylanMcDonald
    Guest
    Quote Originally Posted by mynameis
    What kind of modem is it? Do you have a stand alone router, or it it part of the modem?
    I have a Linksys Wireless Router and an Actiontec Modem. I'm thinking it might be my ISP though.

  5. #5


    Member Since
    Oct 01, 2004
    Posts
    3,378
    you sure it isn't your router settings you are getting when you try to access it with your WAN(External) IP?

  6. #6

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Your router holds the external IP address the world sees. This is picked up by the router from your ISP. The router also has an internal IP address that allows you to maintain it. I think the default in your case is 192.168.1.1.

    Your Mac needs to have a static internal IP address that doesn't conflict with the routers internal IP address, or any other internal IP address. Try 192.168.1.2.

    Now forward port 80 on the router to 192.168.1.2

    As long as web sharing is turn on, on the Mac, this set up should suffice. To test if web sharing is turned on, type http://127.0.0.1 into a web browser.

    If your ISP is blocking port 80, then it gets trickier. The norm is to try port 8080. But you also have to change the Apache web server configuration file to agree with that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •