New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Web Design and Hosting Creating sites, scripting, and hosting discussions.

sending mail through php


Post Reply New Thread Subscribe

 
Thread Tools
buratti

 
Member Since: Jul 09, 2010
Posts: 1
buratti is on a distinguished road

buratti is offline
Hello, I am having a problem sending mail with php while hosting my own website with apache on my mac. First of all I would like to note that I do not have a large background with web hosting and php. Everything that I did so far was just suggestions from online articles and other forums, so please include detail with any answers.

I have apache started, and my website hosted just fine. I can also view php pages so I know php is running too. My problem is using the php mail() function.

I have a simple form in my site who's action attribute is set to results.php. In the results.php file I have the mail() function (along with html code displaying "thank you...blah blah blah") sending info from the form to my email address. I never get an error on the php side, but my mail never gets sent.

Is there some type of setting in a config file that need to be turned on or changed?

Here is what I have done/modified so far from my research from online articles. i dont know what some of them mean, but followed the steps correctly:
  • Edited the /etc/hostconfig file and added the line MAILSERVER=-YES-
  • Edited the /etc/postfix/main.cf file and uncommented the #myhostname = ...line and made it "myhostname = localhost" (without quotes)
  • Edited the php.ini file to the following - The line under where it says
    ; For unix only. You may supply arguments as well (default: "sendmail -t -i")
    Sendmail_path = usr/sbin/sendmail -t -i

I opened the mail.log file and here are some entries from today:
Code:
Jul  9 08:16:50 new-host postfix/master[689]: daemon started -- version 2.4.3, configuration /etc/postfix
Jul  9 08:16:50 new-host postfix/qmgr[691]: 4B4DC2E8331: from=<_www@new-host.home>, size=323, nrcpt=1 (queue active)
Jul  9 08:16:50 new-host postfix/qmgr[691]: 7A8242EE3C0: from=<_www@localhost.alotusbirth.com>, size=280, nrcpt=1 (queue active)
Jul  9 08:16:50 new-host postfix/qmgr[691]: B1C052EE3C4: from=<_www@localhost.alotusbirth.com>, size=280, nrcpt=1 (queue active)
Jul  9 08:16:50 new-host postfix/qmgr[691]: C281C2EE3C5: from=<_www@localhost.alotusbirth.com>, size=327, nrcpt=1 (queue active)
Jul  9 08:16:50 new-host postfix/smtp[694]: 4B4DC2E8331: to=<JBuratti@verizon.net>, relay=relay.verizon.net[206.46.232.11]:25, delay=213262, delays=213261/0.05/0.86/0, dsn=4.0.0, status=deferred (host relay.verizon.net[206.46.232.11] refused to talk to me: 571 Email from 74.102.108.224 is currently blocked by Verizon Online's anti-spam system. The email sender or Email Service Provider may visit http://www.verizon.net/whitelist and request removal of the block. 100709)
Jul  9 08:16:51 new-host postfix/pickup[690]: 0F5D22EE4DB: uid=70 from=<_www>
Jul  9 08:16:51 new-host postfix/cleanup[692]: 0F5D22EE4DB: message-id=<20100709121651.0F5D22EE4DB@localhost>
Jul  9 08:16:51 new-host postfix/qmgr[691]: 0F5D22EE4DB: from=<_www@localhost.alotusbirth.com>, size=333, nrcpt=1 (queue active)
Jul  9 08:16:51 new-host postfix/smtp[695]: 7A8242EE3C0: to=<JBuratti@Verizon.net>, relay=relay.verizon.net[206.46.232.11]:25, delay=27074, delays=27073/0.02/1.1/0, dsn=4.0.0, status=deferred (host relay.verizon.net[206.46.232.11] refused to talk to me: 571 Email from 74.102.108.224 is currently blocked by Verizon Online's anti-spam system. The email sender or Email Service Provider may visit http://www.verizon.net/whitelist and request removal of the block. 100709)
Jul  9 08:16:51 new-host postfix/smtp[697]: C281C2EE3C5: to=<JBuratti@verizon.net>, relay=relay.verizon.net[206.46.232.11]:25, delay=26817, delays=26816/0.02/1.1/0, dsn=4.0.0, status=deferred (host relay.verizon.net[206.46.232.11] refused to talk to me: 571 Email from 74.102.108.224 is currently blocked by Verizon Online's anti-spam system. The email sender or Email Service Provider may visit http://www.verizon.net/whitelist and request removal of the block. 100709)
Jul  9 08:16:51 new-host postfix/smtp[696]: B1C052EE3C4: to=<JBuratti@Verizon.net>, relay=relay.verizon.net[206.46.232.11]:25, delay=27174, delays=27173/0.01/1.1/0, dsn=4.0.0, status=deferred (host relay.verizon.net[206.46.232.11] refused to talk to me: 571 Email from 74.102.108.224 is currently blocked by Verizon Online's anti-spam system. The email sender or Email Service Provider may visit http://www.verizon.net/whitelist and request removal of the block. 100709)
Jul  9 08:17:23 new-host postfix/smtp[694]: connect to mx1.comcast.net[76.96.62.116]: Operation timed out (port 25)
Jul  9 08:17:50 new-host postfix/master[689]: master exit time has arrived
Any other suggestions on how to get this to work? I have also created a simple php file that sends mail without retreiving info from a form and also tried using several different email addresses to send to and from, but still nothing
QUOTE Thanks

Post Reply New Thread Subscribe


« My Blog is all mess mash | Must have Mac apps for web developers »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Mac Mail Stuck on Sending Kinsey OS X - Apps and Games 0 12-23-2009 11:25 AM
PHP mail(); won't work on XAMPP r.mistry6 Web Design and Hosting 2 07-13-2009 07:06 PM
Trying to configure PHP mail() function merlinthefiend Web Design and Hosting 1 02-25-2009 08:34 PM
Mail not playing sound effect when sending mail Straitsfan OS X - Operating System 3 11-06-2008 11:24 AM
Mail Folder "exclusively locked" by user klippe OS X - Apps and Games 3 09-06-2005 07:20 PM

All times are GMT -4. The time now is 11:19 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?