Results 1 to 3 of 3
  1. #1


    Member Since
    Jul 13, 2009
    Location
    UK
    Posts
    3
    Specs:
    OSX 10.5 (Leopard), 4GB RAM, 2.8GHz Core 2 Duo, 360GB HDD - 24" iMac
    PHP mail(); won't work on XAMPP
    (complete PHP/Server-side n00b here)
    Title: PHP mail(); won't work on XAMPP 1.0.1 on OSX 10.5


    Hi there

    I'm coding PHP on Mac OSX 10.5 (Leopard) with the latest version of XAMPP (1.0.1) and I'm having trouble to see why my mail(); won't work. The code seems valid in every way, and it even loads the success statement which its instructed to echo when the function is complete. My only guess is that there is a setting somewhere in XAMPP that is stopping the mail(); from working.

    Any ideas as to what to do? Everything in XAMPP is at its default settings, if that is any help.


    Everything is newly installed and at its default including the php.ini file.

    here is what the current settings are (php.ini) :

    PHP Code:
     // default, untouched.
    [mail function]
    ; For 
    Win32 only.
    SMTP localhost
    smtp_port 
    25

    ; For Win32 only.
    ;
    sendmail_from me@example.com

    ; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
    ;
    sendmail_path 
    I am running this server locally and just want to test my contact form and a newsletter subscription form.


    Any ideas as to what I should do?

  2. #2

    Lewwy's Avatar
    Member Since
    May 21, 2007
    Posts
    198
    Specs:
    15" Macbook Pro, 2.16gz, 2gb RAM || 20" iMac, 2.4gz, 2gb RAM
    I am sure your code is fine, and that it probably should work. I do it differently but there are many ways.

    Nevertheless, I dont think the mail function works on XAMP whatever way you look at it. I couldnt get it to work on MAMP (and I assume they are basically the same thing) but when I uploaded the script to my webserver, it worked fine.



    Try it on a webserver, let me know.

  3. #3


    Member Since
    Jul 13, 2009
    Location
    UK
    Posts
    3
    Specs:
    OSX 10.5 (Leopard), 4GB RAM, 2.8GHz Core 2 Duo, 360GB HDD - 24" iMac
    Quote Originally Posted by Lewwy View Post
    I am sure your code is fine, and that it probably should work. I do it differently but there are many ways.

    Nevertheless, I dont think the mail function works on XAMP whatever way you look at it. I couldnt get it to work on MAMP (and I assume they are basically the same thing) but when I uploaded the script to my webserver, it worked fine.



    Try it on a webserver, let me know.
    It works fine on the webserver. I didn't have any doubt with my code, it just would have been nice to have a local mailserver possibility setup on the mac so that I don't have to upload files everytime online just to test out small features such as this one.

    thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. after lion install Mail won't work
    By oddjobbb in forum OS X - Apps and Games
    Replies: 1
    Last Post: 07-21-2011, 12:18 AM
  2. XAMPP for Mac (PHP)... Need HELP!
    By 9homie in forum OS X - Apps and Games
    Replies: 1
    Last Post: 06-12-2008, 09:21 AM
  3. Mail won't work
    By tacsniper in forum OS X - Apps and Games
    Replies: 4
    Last Post: 11-09-2007, 10:08 PM
  4. PHP email form won't work
    By reholmes in forum OS X - Operating System
    Replies: 0
    Last Post: 07-15-2007, 04:39 PM
  5. Mail won't work with .Mac
    By Maxp0wer2004 in forum OS X - Apps and Games
    Replies: 4
    Last Post: 07-19-2005, 01:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •