New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Web Design and Hosting Creating sites, scripting, and hosting discussions.

flash cannot load on local host


Post Reply New Thread Subscribe

 
Thread Tools
limazita

 
Member Since: Mar 09, 2009
Posts: 6
limazita is on a distinguished road

limazita is offline
Hi,

I am trying to use the localhost server on my macbook for website development (instead of doing testing by ftp). I downloaded the files from my webserver to the Site folder on my macbook. The Apache is running. My site is flash and make use of the SWFAddress class. The AC_RunActiveContent.js file is in the same folder as the index.html file. When I try to open the page http://localhost/~USERNAME/mysite in firefox, the title and favicon loaded properly, but the embedded flash could not be displayed. However, the same set of files works alright on the remote web server.

I thought it might be problem with the directory and I have tried ./swf/home.swf, swf/home.swf, /swf/home.swf in the index.html file but none work.

What may be the problem?

The directory structure is as follows :

mysite
--index.html
--AC_RunActiveContent.js
--swf (folder)
----home.swf

Code:
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<link rel="icon"  href="favicon.ico"/>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Photography</title>
<script language="javascript">AC_FL_RunContent = 0;</script>
<script src="AC_RunActiveContent.js" language="javascript"></script>
</head>
<body bgcolor="#ffffff">
<p align = "center">
<!--url's used in the movie-->
<!--text used in the movie-->
<!--
PHOTOGRAPHY
-->
<!-- saved from url=(0013)about:internet -->
<script language="javascript">
	if (AC_FL_RunContent == 0) {
		alert("This page requires AC_RunActiveContent.js.");
	} else {
		AC_FL_RunContent(
			'codebase', 'http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0',
			'width', '1000',
			'height', '700',
			'src', 'swf/home',
			'quality', 'high',
			'pluginspage', 'http://www.macromedia.com/go/getflashplayer',
			'align', 'middle',
			'play', 'true',
			'loop', 'true',
			'scale', 'showall',
			'wmode', 'window',
			'devicefont', 'false',
			'id', 'swf/home',
			'bgcolor', '#ffffff',
			'name', 'swf/home',
			'menu', 'true',
			'allowFullScreen', 'false',
			'allowScriptAccess','sameDomain',
			'movie', '../swf/home',
			'salign', ''
			); //end AC code
	}
</script>
<noscript>
	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="1000" height="700" id="swf/home" align="middle">
	<param name="allowScriptAccess" value="sameDomain" />
	<param name="allowFullScreen" value="false" />
	<param name="movie" value="/swf/home.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
	<embed src="/swf/home.swf" quality="high" bgcolor="#ffffff" width="1000" height="700" name="swf/home" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
	</object>
</noscript>
</p>
</p>
</body>
</html>
Thanks a lot for taking a look
QUOTE Thanks
limazita

 
Member Since: Mar 09, 2009
Posts: 6
limazita is on a distinguished road

limazita is offline
I already tried changing all the swf/home or ../swf/home.swf or whatever to swf/home.swf but still the flash does not load.

I am posting this index.html coz despite all the discrepancies, it works on the remote server
QUOTE Thanks

Post Reply New Thread Subscribe


« Can you recommend a laptop for web design? | What do you think would be the best.... »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Local host name Already in Use??? code777 OS X - Operating System 6 06-01-2012 10:13 AM
How to insert Flash movie (shockwave) into PowerPoint slideshow? ChrisBale Running Windows (or anything else) on your Mac 0 09-09-2008 06:07 AM
Time Machine - Local Host Error Message MacNNJ Running Windows (or anything else) on your Mac 0 03-21-2008 11:20 AM
Not sure how i should go about creating this flash to accomplish what i need. damainman Web Design and Hosting 1 11-20-2007 01:39 AM
local host vic one Web Design and Hosting 8 02-06-2005 03:21 PM

All times are GMT -4. The time now is 12:08 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?