Results 1 to 3 of 3
  1. #1

    Seastud's Avatar
    Member Since
    Jun 05, 2008
    Location
    Ontario Canada
    Posts
    26
    Specs:
    Blackbook. 2.4 Duo 4gb Ram 250gb HD . Ipod, Ipod shuffle.
    Iweb won't open site.
    I built a site using Iweb.
    I worked fine for a month but now all pages have the following code in line 1 and Iweb now says it can't open the site. When I view the site on my HD it opens in Safari fine but the uploaded site gives an error of "Parse error: syntax error, unexpected T_STRING in /home/seastud/public_html/Trevor/Trevor.html on line 1"

    Code in line 1
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    I just want to open in Iweb to fix or is there another option other than opening in text?

    PS: I have no idea where this code came from. I didn't put it there.

  2. #2

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Your message is a bit confusing to me but I suspect you are confusing what iWeb edits and what it produces (publishes) for consumption by web browsers.

    First, iWeb inserts those lines as they are part of the standards for the page it is publishing (creating) for use in a web browser.

    iWeb does NOT edit html files directly. It has it's own file structure. Double click the "/home/seastud/Library/Application Support/iWeb/Domains.sites2" file. I'm assuming you are using the latest iWeb, otherwise the file extension may be slightly different. This will allow you to edit your work.

    Did you upload Trevor.html to a remote site, and that is not working?

    Remember, you edit in iWeb (it stores those edits in a special place), publish to .Mac or a folder. If you publish to a folder, you upload that to your site. You never directly edit the published content, so never right click that content to open in iWeb. That won't work.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

  3. #3

    Seastud's Avatar
    Member Since
    Jun 05, 2008
    Location
    Ontario Canada
    Posts
    26
    Specs:
    Blackbook. 2.4 Duo 4gb Ram 250gb HD . Ipod, Ipod shuffle.
    Thanks will give that a try.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iWeb won't open
    By lmburns in forum Web Design and Hosting
    Replies: 0
    Last Post: 10-20-2012, 09:20 AM
  2. Have I lost my iWeb/Site?
    By Sl33pyh34d in forum Web Design and Hosting
    Replies: 0
    Last Post: 11-01-2011, 04:02 AM
  3. Hyperlink won't work when my iWeb site is published
    By nigelivy in forum Web Design and Hosting
    Replies: 3
    Last Post: 10-27-2009, 12:37 PM
  4. iWeb: open previous site!!!
    By Christopher in forum Web Design and Hosting
    Replies: 0
    Last Post: 06-26-2007, 11:19 AM
  5. Why is iWeb site not looking right
    By greyS60 in forum Web Design and Hosting
    Replies: 9
    Last Post: 10-12-2006, 12:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •