Results 1 to 5 of 5
  1. #1
    I screwed up big time! Can anyone help?
    Well, I got my mac off ebay around a month ago. Things have been wonderful. Nothing but good experiences.

    Earlier tonight I was trying to change the short name of my account, since the brilliant mind I bought it from named it 'macmac' and that wasn't quite... me. Of course I probably should have left it as it was, but being the fickle person that I am, I attempted to change it.

    I downloaded the program called "ChangeShortName" after reading the programmer hype it about being super easy and such.

    So I ran the program, and apparently the shell program finished. I then logged out and back in as my new short name, "khan". Well apparently the program didn't work completely, because I didn't have any admin privliges and there was still a folder for macmac in the User folder, but I didn't have an option for logging in as macmac at the OSX Login screen, so I decided to read the instructions that came with the program and attempt to restore the backup to the way it was before I got this horrible idea of trying to change it in the first place...

    So I rebooted to single-user mode as the documentation told me to. I mounted the drive by doing /sbin/mount -uw / <return> and things seemed to be going smoothly. I then did the rest of the commands as stated.

    cd /var/db/netinfo <return>
    mv local.nidb local.nidb.bad <return>
    nicl -raw local.nidb -create <return>
    niload -d -r / -t localhost/local < local-ChangeShortNameBackup-Aug192004.nidump <return>

    When I do that last command it says "cannot connect to server localhost/local: communication failure" so I tried rebooting the computer. When the password screen comes up, I can only attempt to log in as "Other" but none of the username/passwords I had work.

    So then I rebooted and attempted to rename the local.nidb.bad back to local.nidb, but I still only get the "Other" user option.

    Anyone have any ideas? This will teach me never to mess with things of this nature ever again


  2. #2
    I fixed the problem. Just deleted the .AppleSetupDone file and resetup an account with the original shortname. Everything is fine now, thanks for the help.

  3. #3

    Avalon's Avatar
    Member Since
    Jun 25, 2004
    Luxemburg, Europe
    PowerMac G5 Dual 2GHz (June 2004), 2.5GB, Airport, black 5G iPod 30GB, white MacBook 2.0 2GB
    Good for you...
    You should just simply have created a new user with your name, and deleted the "macmac" user...without messing around with the user shortname...
    That would have been the easy way

  4. #4's Avatar
    Member Since
    Mar 27, 2004
    Dual 2.2GHz powered by AMD Opteron - *Sends G5 & 8Gb Ram to scrap heap* Yeah! finally switched BACK!
    Hmm.. When you brought the system why didn't you do a fresh installation? I assume they sent you the manual and the original media pack right? So you have all the instruction there, in hard copy.

  5. #5
    Nope, no manual or osx cd. So I was screwed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Time Machine screwed me!!!!!!!
    By fleurya in forum OS X - Apps and Games
    Replies: 4
    Last Post: 04-14-2008, 01:29 AM
  2. big help guys. really screwed it up!
    By raptorkid700 in forum iPod Hardware and Accessories
    Replies: 8
    Last Post: 03-11-2008, 05:43 PM
  3. i tunes is getting on my nerves big time
    By soundsystem00 in forum Switcher Hangout
    Replies: 4
    Last Post: 12-19-2007, 06:56 PM
  4. Yea so i messed up big time.....
    By damainman in forum Switcher Hangout
    Replies: 23
    Last Post: 11-18-2007, 11:41 PM
  5. So far Time Machine is a Big disappointment.
    By ret63 in forum OS X - Operating System
    Replies: 16
    Last Post: 10-29-2007, 04:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts