New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Switcher Hangout The place for switchers to discuss their new machines, and how to work with OS X. General support can be had here for newbie stuff, like "How do I restart my new iMac?" :)

Auto dimming screen


Post Reply New Thread Subscribe

 
Thread Tools
Thundermoon1994

 
Thundermoon1994's Avatar
 
Member Since: Dec 26, 2006
Location: Kent, OH
Posts: 495
Thundermoon1994 will become famous soon enough
Mac Specs: 15" MacBook Pro w/ 2.4 GHz C2D, 4 GB RAM, 250 GB

Thundermoon1994 is offline
I'm new to this site and to Macs so please don't jump all over me if this is a stupid question. I have an ibook and I want to disable the autodimming feature. What i mean by that is my screen goes dim if I don't do anything for a little while (such as watching a movie). Is there a way to turn this off?

~Damien
QUOTE Thanks
ToddG

 
ToddG's Avatar
 
Member Since: Nov 27, 2006
Posts: 2,073
ToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant future

ToddG is offline
Thundermoon1994 -- Not a stupid question.

Click on the blue Apple in the top left corner of your screen and choose "System Preferences."

Click on "Energy Saver" which is the little lightbulb icon on the second row of the dialog box that comes up.

In the "Settings for:" box, you will need to select Power Adapter. Click on "Options" and then under "Other Options" make sure there is no check mark next to "Automatically reduce the brightness ..."

Then go back to the "Settings for:" box and select Battery. Again, uncheck the box for "Automatically reduce the brightness ..."

You might also want to go to the "Display" icon on the "System Preferences" page, and make sure that "Automatically adjust brightness as ambient light changes" box is unchecked.
QUOTE Thanks
Thundermoon1994

 
Thundermoon1994's Avatar
 
Member Since: Dec 26, 2006
Location: Kent, OH
Posts: 495
Thundermoon1994 will become famous soon enough
Mac Specs: 15" MacBook Pro w/ 2.4 GHz C2D, 4 GB RAM, 250 GB

Thundermoon1994 is offline
Thanks a lot, Todd. By the way, I have a shirt with your signature quote on it.

~Damien
QUOTE Thanks
ToddG

 
ToddG's Avatar
 
Member Since: Nov 27, 2006
Posts: 2,073
ToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant futureToddG has a brilliant future

ToddG is offline
Really? Where'd you get it?
QUOTE Thanks
EDIT-XTREEM

 
EDIT-XTREEM's Avatar
 
Member Since: Jun 27, 2005
Location: In the mac store and at home on my iMac
Posts: 1,165
EDIT-XTREEM has a spectacular aura about

EDIT-XTREEM is offline
Welcome to the Forums!

Mac Pro (Early 2009) 8 Core 2.26 GHz, 6 GB Ram, 640 GB Drive. Dell 2408WFP.
QUOTE Thanks
rockinstlouis

 
Member Since: Jan 11, 2007
Posts: 1
rockinstlouis is on a distinguished road

rockinstlouis is offline
yes this does work.. and i believe that this a permanent fix for some people.. but in my case, whenever my iMac is rebooted, the setting breaks.. you have to set it every time you reboot.. I've read this on other sites, so I know other people have this problem..

i've done many hours on research on this issue.. i must credit Sam Elowitch on MacinTouch.com for his efforts on this too.. this is a great script to fix this problem..

use AppleScript to paste this into..


do shell script ("pmset halfdim 0") password
"your_password" with administrator privileges


the ONLY thing you need to change here is the "your_password" section.. do not delete the quotes.. and you must insert that bracket thing on line 1.. that can be found on the character map from the Edit menu... Save it as an application, no startup screen, somewhere on your hard drive. Then, under System Preferences --> Accounts, assign this new application as a Login Item.

lots of steps yes.. but definitely worth the effort if you haven't gotten the silly issue fixed..

Mike
QUOTE Thanks
Thundermoon1994

 
Thundermoon1994's Avatar
 
Member Since: Dec 26, 2006
Location: Kent, OH
Posts: 495
Thundermoon1994 will become famous soon enough
Mac Specs: 15" MacBook Pro w/ 2.4 GHz C2D, 4 GB RAM, 250 GB

Thundermoon1994 is offline
Quote:
Originally Posted by ToddG View Post
Really? Where'd you get it?
My fiance bought it for me at Hot Topic a while back.

Quote:
Originally Posted by EDIT-XTREEM View Post
Welcome to the Forums!
Thanks!


~Damien
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,500
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by rockinstlouis View Post
yes this does work.. and i believe that this a permanent fix for some people.. but in my case, whenever my iMac is rebooted, the setting breaks.. you have to set it every time you reboot.. I've read this on other sites, so I know other people have this problem..

i've done many hours on research on this issue.. i must credit Sam Elowitch on MacinTouch.com for his efforts on this too.. this is a great script to fix this problem..

use AppleScript to paste this into..


do shell script ("pmset halfdim 0") password
"your_password" with administrator privileges


the ONLY thing you need to change here is the "your_password" section.. do not delete the quotes.. and you must insert that bracket thing on line 1.. that can be found on the character map from the Edit menu... Save it as an application, no startup screen, somewhere on your hard drive. Then, under System Preferences --> Accounts, assign this new application as a Login Item.

lots of steps yes.. but definitely worth the effort if you haven't gotten the silly issue fixed..

Mike
+1 rep for rockinstlouis! That's very handy.
QUOTE Thanks

Post Reply New Thread Subscribe


« Switching to mac: The missing manual | Switchers, what is your main web browser? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
MAC G5 interface with dell screen - please help!!!! Intravenusdemil OS X - Operating System 2 09-13-2009 06:44 AM
screen auto zooms on startup ???? barrett Other Hardware and Peripherals 1 08-03-2006 02:31 PM
Auto Dimming: How to Totally Disable? geekboy2000 Apple Desktops 0 05-23-2006 11:02 PM
dimming screen is driving me CRAZY tomasismyname Apple Notebooks 10 07-14-2005 12:11 PM
Screen dimming Benjamindaines OS X - Operating System 1 05-14-2005 05:52 AM

All times are GMT -4. The time now is 06:52 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?