Results 1 to 7 of 7
  1. #1


    Member Since
    Jan 18, 2006
    Posts
    1,868
    Specs:
    G4 Cube
    How to disable spellcheck system-wide?
    Spellcheck bugs me; anyone know how to disable it throughout the system? You can disable it in individual applications by right-clicking a text area and then unchecking "Check Spelling as you Type" in the Spelling menu. I use a lot of computer terminology when I type and the spellchecker doesn't understand the majority of it, so I get the annoying red underlines.
    Mac Sites - down for reconstruction

  2. #2

    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    is this a question or a solution? the best way for it to not bug you is learn from your mistakes and learn how to spell and punctuate properly.
    -chris
    MoTM honor roll...
    when?
    i dont remember

  3. #3


    Member Since
    Mar 11, 2004
    Posts
    1,964
    The spell checker in TextEdit , for instance, drove me nuts until I discovered I could change the default dictionary to Canadian English. Doing so ended the irritating red lines under correctly spelled words.

    If the wrong dictionary is the problem and continuing with TextEdit, since it's common on both our machines right-click on a word in a TextEdit document and choose Spelling, then in the submenu choose Spelling again. You can change the dictionary at the bottom-left.

    I also found Canadian English within the International preferences in the Mac's system preferences. By choosing Edit List, I deselected English, then by scrolling down found and chose Canadian English.

    That doesn't change anything in the Mac's dictionary, though. It still says that "colour" is the British spelling, rather than pointing out that "color" is correct in only one of at least 41 English-speaking countries.

  4. #4


    Member Since
    Jan 18, 2006
    Posts
    1,868
    Specs:
    G4 Cube
    Quote Originally Posted by coach_z
    is this a question or a solution? the best way for it to not bug you is learn from your mistakes and learn how to spell and punctuate properly.
    -chris
    This is a question I just updated the first post to clarify my question. The stuff in parenthesis refers to the option I'm talking about. The best way for it not to bug me is to turn it off; I often make little notes in Stickies or TextEdit with computer terminology that the spellchecker doesn't understand, so my notes are filled with the red underlines. It bugs me
    Mac Sites - down for reconstruction

  5. #5


    Member Since
    Mar 11, 2004
    Posts
    1,964
    You can turn TextEdit's spell check off as its default setting in TextEdit's preferences (then quit TextEdit and restart it). You can then turn it on for individual documents by choosing Spelling under Edit.

    Stickies doesn't have any preferences. All I could do was to turn off the spell check each time I started the app (by going to Spelling under Edit).

  6. #6

    ekologik's Avatar
    Member Since
    Dec 03, 2007
    Location
    Canada
    Posts
    74
    Specs:
    MacBook 2.4 GHz Intel (unibody), 2 GB RAM; iPhone 3Gs
    Quote Originally Posted by Brown Study View Post
    I also found Canadian English within the International preferences in the Mac's system preferences. By choosing Edit List, I deselected English, then by scrolling down found and chose Canadian English.

    That doesn't change anything in the Mac's dictionary, though. It still says that "colour" is the British spelling, rather than pointing out that "color" is correct in only one of at least 41 English-speaking countries.
    great! thanks. been wondering this for a while.
    MacBook
    iPhone 3Gs

  7. #7

    Likugha's Avatar
    Member Since
    Nov 14, 2007
    Location
    Oregon
    Posts
    55
    Specs:
    MacBook 2 GHz Core Duo ! GB 667 MHz DDR2 SDRAM
    did you ever think to start hitting "learn" eventually it would clear itself up but as far as what your asking IDK never thought or wanted to try tp turn it off

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-29-2010, 01:29 PM
  2. Security issue: lockpad doesn't work system wide
    By Riba in forum OS X - Operating System
    Replies: 3
    Last Post: 10-08-2009, 03:04 PM
  3. Disable Mac System Preferences
    By MacTech1 in forum OS X - Operating System
    Replies: 3
    Last Post: 03-08-2009, 12:49 PM
  4. How to disable spellcheck system-wide in Leopard?
    By kaidomac in forum OS X - Operating System
    Replies: 6
    Last Post: 03-07-2008, 11:07 PM
  5. System Wide Font Issue.
    By crashdown in forum OS X - Operating System
    Replies: 2
    Last Post: 10-12-2005, 04:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •