I'm in my third week of the switch from XP to OSX and I'm encountering some problems with (1) wireless networking, and (2) .Mac sync'g. I've got an Intel iMac and a g4 iBook (both new).

1) Wireless Network -- I'm using a Linksys 802.11b router/access point (soon to upgrade to an extreme base) and both machines generally see the internet connection fine. I say "generally" because for some reason yesterday they kept dropping the connection, and when reviewing the configuration in System Pref/Network it seemed that the WEP password has some exta characters added (these area is locked so an accidental input is highly unlikely, and I paste the password in from my "password vault" so misstyping is also highly unlikely).

More importantly, the iBook and the iMac do not "see" each other. I've set the global Sharing up as well as each user home file using the individual "get info" screen (setting both group access [network] to read/write and other users to read/write). Still, each computer does not see the other one.

Any ideas?

2) Some how, my wife deleted her Entourage mail box on the iMac. I reestablished, but she lost all her contacts. No worries, I thought, she has an .Mac account that is set to sync contacts/address book. After confirming the sync setting both in Entourage and the .Mac system pref (and ensuring the iMac was registered with .Mac), I manually sync'd . . . nothing. No worries, I thought -- she still has all her contacts on the iBook. Logged in there and the mail box there was gone (like the iMac it had been "deleted," except she had not been on the iBook). So I reestablished the mail box and now the contacts there are gone. But on .Mac (on the web) all the contacts are there. But I cannot get either machine to sync up with .Mac. It appears to "sync," i.e., no error messages, icons change showing that something is happening. Yet no address data comes over.

Edited to add: After confirming the .Mac address book contained all her contacts, I took the somewhat drastic step of de-registering both computers from .Mac -- thinking that somehow .Mac didn't see both computers as "needing" its data (sync dates or something). Re-registering both computers seem to "reset" the sync since the machines both asked what to do with the "new" data (I said "merge with existing" so that, in theory, each machine would get everything). No luck. Contacts are still on .Mac, but not on either machine.

I realize there's a lot going on here, but if any one has any thoughts I'd love to hear them. Without blowing my horn, I'm quite computer literate in the Win environment and computers generally, but have no experience with Mac's other than now.