Results 1 to 5 of 5
  1. #1

    Member Since
    Jul 25, 2013
    Unable to locate downloaded app
    I'm a new Mac user with a Mac Mini (10.8.4). I downloaded MagiCal (both the Intel version and the Universal version), but I can't find them. (It's a clock/calendar app). I restarted my computer. I went to Downloads and tried to Move to Trash, but I can't because they are supposedly open. Can you help me find them? Thanks

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    First, the Universal version will not work with Mountain Lion because it contains PPC code. The Intel version, however, should work as the author states. MagiCal should have downloaded to whatever you have your browser setup for a download folder. Check your browser's options to see what you have setup for a download folder. By default, Safari will download to your "Downloads" folder. Chrome and Opera likewise. I don't use Firefox but I suspect its default is the same.

    If you still can't find where it's at, use your Spotlight Search feature. (Magnifying glass in the upper right corner of your top menu.)

  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11
    Go into Finder in the Dock (the back to front face), select Downloads and see if it is there.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  4. #4

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Jeff indicates in his post that he's already found the downloads -- in his downloads folder, precisely where they are supposed to be. I suspect that what he might have done is opened the programs from the disk image and they are still open -- which would explain why he can't trash the disk images.

    This may help: Installing Applications in Mac OS X - Mac Guides

  5. #5

    Member Since
    Jul 25, 2013
    Thanks for your help. Problem solved!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to Locate App/File to Uninstall
    By Mileman2010 in forum OS X - Operating System
    Replies: 7
    Last Post: 06-14-2011, 02:47 PM
  2. unable to locate apps?
    By Lostwind in forum iOS and Apps
    Replies: 0
    Last Post: 10-19-2009, 12:47 AM
  3. unable to locate drives and folders
    By MannyForbes in forum Apple Notebooks
    Replies: 1
    Last Post: 10-06-2009, 07:34 AM
  4. Unable to locate iTunes library?
    By BethanyLieb in forum Music, Audio, and Podcasting
    Replies: 1
    Last Post: 06-14-2009, 11:17 PM
  5. unable to install firefox downloaded today
    By gvijaypurkar in forum Switcher Hangout
    Replies: 14
    Last Post: 03-19-2007, 07:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts