New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Switcher Hangout The place for switchers to discuss their new machines, and how to work with OS X. General support can be had here for newbie stuff, like "How do I restart my new iMac?" :)

HELP! Safari not playing videos


Post Reply New Thread Subscribe

 
Thread Tools
MACelmore

 
Member Since: Mar 11, 2013
Posts: 12
MACelmore is on a distinguished road

MACelmore is offline
When I first got my rMBP I had downloaded Google Chrome and was using it exclusively, because that's what I was used to. I recently decided to start using Safari and fell completely in love with it. Only one problem...... IT WON'T PLAY ANY FLASH CONTENT!

I downloaded Adobe Flash Player when I first got the machine, and videos work great in Chrome. When I switched to Safari, and it wouldn't play videos, I figured I would uninstall and re-download Adobe using Safari. Didn't work!!!

Any suggestions?
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,560
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
First Chrome has it's own Flash player. What happens in Safari when you say open a You Tube video? What is the error? No Flash? If that is the case the Flash Plug in is NOT installed.
QUOTE Thanks
MACelmore

 
Member Since: Mar 11, 2013
Posts: 12
MACelmore is on a distinguished road

MACelmore is offline
Oh, well that makes sense.

And yes, it says that there is no Flash player.
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,560
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Did you have Safari closed when installing Flash? If not the Plug in will not install.
QUOTE Thanks
MACelmore

 
Member Since: Mar 11, 2013
Posts: 12
MACelmore is on a distinguished road

MACelmore is offline
Yes absolutely. Here's the thing. Chrome will be closed and Safari will be open. After the installation is complete, the confirmation window opens that says "Your Installation Was Successful", but it opens in CHROME! Not Safari.

I've installed and uninstalled and restarted, then rinse and repeat so many times. I have no idea.
QUOTE Thanks
MACelmore

 
Member Since: Mar 11, 2013
Posts: 12
MACelmore is on a distinguished road

MACelmore is offline
As I was typing that, it occurred to me that Safari wasn't set up as my default browser. Duh! Thanks for listening to me! Haha
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,560
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Yes, that might do it for you. If not let us know!
QUOTE Thanks
Aqua

 
Aqua's Avatar
 
Member Since: Sep 05, 2007
Location: Canada
Posts: 452
Aqua has a spectacular aura about
Mac Specs: Macbook Pro, 2.4GHz Core2 Duo 10.6.8, MacMini

Aqua is offline
I think also mac disables Flash (I know it was an update on Snow Leopard) so you should check that and hopefully someone will know what to do.

invincible ignorance is an example of ignorance that can not be removed by any amount of evidence. It's now a widespread form of pollution. (Revised quote) An apple a day, keeps the psychiatrist away.. If you play a Windows install CD backwards it has satanic verses
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,560
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Lion was the first version of OSX not to ship with Flash installed. Snow Leopard had Flash and Rosetta also. It's a simple matter to download and install Flash if you need it. It's not disabled as such, just not included in the install.
QUOTE Thanks
san1244

 
Member Since: Feb 01, 2009
Posts: 17
san1244 is on a distinguished road

san1244 is offline
Easy fix. Run Disk Utility/Verify Disk Permissions/Repair Disk Permissions/Reboot.
QUOTE Thanks

Post Reply New Thread Subscribe


« Classic iTunes question | question for Firefox for Mac users »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Full frame videos in Safari Nitram OS X - Operating System 0 12-12-2012 12:01 PM
Embedding Vimeo videos in Safari? drgrafix Switcher Hangout 1 09-15-2012 06:03 PM

All times are GMT -4. The time now is 12:30 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?