Results 1 to 8 of 8
  1. #1

    Member Since
    Sep 29, 2012
    iMac ejecting USB mass storage devices and DVD's
    Hi there, I hope someone can assist me. I am not great with computers at all. I have an iMac which I bought in 2010, I am running OS X mountain lion. It seems that since I did the upgrade to mountain lion my iMac is ejecting any and all disc's and any USB mass storage devices, before I am able to complete copying files to or from the device.
    Everything worked fine until I did the upgrade.
    Any thoughts on how to correct this will be appreciated.

  2. #2

    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    27" i7 iMac, 24" iMac, 13" Macbook Air, iPhone 5 & 5S, iPod Nano 7th Gen, iPad 2 16GB WiFi, iPad 3
    Do the disc and USB devices show up on the desktop and Finder then just go away? Does the disc actually physically eject from the iMac? Can't imagine what in the OS upgrade would cause this sort of failure..

    Be sure to read the Community Guidelines | The more information you provide, the better answers you get, remember GIGO.

  3. #3

    Member Since
    Sep 29, 2012
    Hi there, thanks for your response.

    Yes the USB devices do show on both the desktop and in Finder and just disappear halfway through my download, and the Discs physically eject. I discovered the disc problem when trying to install Office for Mac so tried again with a music CD to check if maybe there was a fault with the Microsoft disc but the same happened with the music disc. Do you think that maybe I have a virus of sorts on my iMac?

  4. #4

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    As there aren't any Mac viruses, the answer to your question would be no.

    Sounds like the eject command is being invoked involuntarily. Could you be pressing the eject key? Could that key have gotten damaged?

  5. #5

    Member Since
    Sep 29, 2012
    Thanks for your input, I have tried with my USB keyboard and still happening. This keyboard and my printer do not "auto eject" like the storage devices, why would that be?

  6. #6

    Adric's Avatar
    Member Since
    Mar 28, 2012
    Atlanta, GA
    27" iMac (Mid 2011), 3.4GHz Intel Core i7, 16GB RAM, 2GB Video Card, 2TB HDD
    They don't auto eject because keyboards and printers don't have to be mounted as disk images by OSX. You can't browse a keyboard or a printer.

    Sounds like your Mac has a case of the Poltergeists! Have you tried running Disk Utility to make sure everything is in order there? It's sounding like whatever component in OSX that mounts disc images has gone haywire. Might be worth it to just go ahead and call Apple Customer Support...

  7. #7

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Try resetting the System Management Controller on your iMac first. Do this:

    Unplug your iMac from the AC outlet (shut it down first), and let it set unplugged for about 10 minutes. Plug it back in and reboot. Let us know if that works.

  8. #8

    docx's Avatar
    Member Since
    Apr 30, 2012
    Wales, UK
    I Mac 27-inch 2.7 GHz Intel Core i5 12GB ram. MacBook Pro 13-inch 2.5GHz dual-core Intel i5 4GB ram

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Large DVD Movie Storage Devices
    By Tunnelrat69 in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 08-18-2014, 01:50 PM
  2. Using USB and storage devices
    By janetp62 in forum Movies and Video
    Replies: 3
    Last Post: 11-13-2012, 03:04 AM
  3. iMac: Ejecting Devices & Network Speed
    By muraii in forum OS X - Operating System
    Replies: 0
    Last Post: 10-13-2007, 03:30 PM
  4. Safely remove USB Mass Storage Device
    By verbatim210 in forum Switcher Hangout
    Replies: 7
    Last Post: 09-29-2007, 04:47 AM
  5. Mass Storage on Paper!!!!
    By in forum Apple Rumors and Reports
    Replies: 18
    Last Post: 06-08-2005, 09:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts