Results 1 to 2 of 2
  1. #1

    Member Since
    Nov 10, 2011
    Samsung 2TB HDD not recognized in Disk Ultility
    Hey guys...

    I bought a big ole external harddrive from Samsung about a month ago, and it worked like a charm on my iMac the first couple of days... (My iMac is Intel, 3.06 GHz, 4 GB DDR3 Ram, Snow Leopard vs. 10.6.8)...

    Then I stopped using it for a week or two, and now I cant get it to show up in my finder when I plug it in... The lights on the drive is on, it makes those classic purring noises just like before, but it simply does not show up in my finder, so I cant access all my beloved por... erm, vacation photos...

    I had a look in my Disk Utility, but it doesn't show up there either...

    What could be wrong...? Have you ever encounted a harddrive that wouldn't show up in your finder..?

    - I already tried to switch the usb cable from another external hdd, but that didn't work either... And unfortunately, being the poor student that I am, I only have this one computer, so I can't even test it out on another...

    I really hope you guys know what to do, because I payed big bucks for that hdd, and most of my work from school is on there...


    // Nowa

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    I hate to tell you this, but it sounds like your Samsung has died an early death. About the only suggestion I can give a poor student is to get an RMA from Samsung and have them send you a new drive. You could try to extract your data from the dead drive but if it doesn't show in Disk Utility, recovery software will likely not work either.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 500gb WD My Passport suddenly not recognized, won't reformat,says 2TB in Disk Utility
    By Jennifer3241 in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 11-13-2010, 03:03 AM
  2. Seagate Free Agent 2TB External HDD
    By bauerod in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 05-06-2010, 06:21 PM
  3. 2TB Iomega HDD Cannot be Erased
    By zevimetal in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 08-01-2009, 02:38 PM
  4. samsung S850 camera is not recognized by iphoto 6
    By marz in forum Images, Graphic Design, and Digital Photography
    Replies: 1
    Last Post: 07-29-2008, 06:37 PM
  5. Trouble with Disk Ultility
    By benavidez in forum OS X - Apps and Games
    Replies: 2
    Last Post: 03-06-2007, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts