From what i've been able to find, it seems the general consensus is that when you have the "automatically use spell checker suggestion" engaged, then there is no way to keep the word as originally typed, which the spell checker continues to replace with something you don't want. Is that it? There really are no options or keyboard commands to returning to the original word and keeping it?

Back when I used Outlook, you could use some kind of key command to return the word back to how you originally typed/spelled it. (Although, I can't remember exactly what it was, I think like "command" and "backspace" at the same time). Lion/Pages doesn't have anything like that?

Example: typed and wanted "Mulcahy", but spell checker kept changing it to "Mulch".

I actually want to use the automatic setting, but this one thing makes it frustrating. I've played with different kind of key commands, and I've searched other forums, and have not found an answer other than "uncheck the box for "automatically use..." I just wanted to be sure I posted it specifically enough to see if there actually was an answer. So, sorry about the long post.