Results 1 to 8 of 8
  1. #1

    Member Since
    Jul 18, 2011
    how to delete a dmg file
    Hi, I do not know I am having the same problem. I saved some file by using disk utility and was able to open using the password that I set. But, once my mac crashed and got repaired, I had to recover all the files( including the dmg files) and stored it in DW passport. When I connect the Passport to Mac and tried to delete the dmg files, I was not able to. It says, this file cannot be deleted.Please help.....

  2. #2

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    Note: moved to it's own thread.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  3. #3

    Dysfunction's Avatar
    Member Since
    Mar 17, 2008
    Tucson, AZ
    Way... way too many specs to list.
    Does it give a reason why?

    In use, no permissions, etc
    This machine kills fascists
    Got # ? phear the command line!

  4. #4

    Member Since
    Jun 26, 2011
    Did you ever eject the dmg on your desktop?

  5. #5

    Member Since
    Jul 18, 2011
    how to delete dmg files
    It says the disc cannot be mounted. The file is locked and it does not ask the password to open or I cannot remove the selection of locked as it is inactive. I tried to eject and delete it. but the original is still there.

  6. #6

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Try changing permissions. Right click on the dmg file and select "get info". On the bottom of the dialog box that opens you'll see the permissions for the dmg file. Click on the small lock at the bottom and enter your admin password. The lock should open. Once it opens, change the permissions to read and write. Exit the dialog and try once more to delete the file.

  7. #7

    Member Since
    Jul 18, 2011
    how to delete dmg files
    Yes, I tried to do that too. It says that it is a read only file. when I set it up, it was read and write. I do not know how it turned in to read only. ' locked' is inactive too. Anyway, thanks for the reply.

  8. #8

    Member Since
    Jun 06, 2012
    Exclamation I had the same problem
    I accidentally downloaded 7zX and couldn't trash it. I went into finder to get my uninstaller utility but then i realised it wasn't ejected so I ejected it and then trashed is and now im good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. .dmg won't delete in trash
    By vincesumergido in forum OS X - Operating System
    Replies: 2
    Last Post: 07-03-2015, 03:12 PM
  2. Can't find .xltx file to delete / delete template excel 2011
    By sessions500 in forum OS X - Operating System
    Replies: 1
    Last Post: 05-07-2012, 08:30 PM
  3. My .dmg file won't update the capacity when I delete files
    By cide28 in forum OS X - Operating System
    Replies: 3
    Last Post: 05-05-2008, 02:32 PM
  4. delete .dmg?
    By sunshine1084 in forum OS X - Operating System
    Replies: 7
    Last Post: 09-21-2006, 01:27 AM
  5. .dmg file
    By boarderjosh10 in forum Switcher Hangout
    Replies: 4
    Last Post: 11-18-2005, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts