New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Switcher Hangout The place for switchers to discuss their new machines, and how to work with OS X. General support can be had here for newbie stuff, like "How do I restart my new iMac?" :)

my mac does not sound any more...


Post Reply New Thread Subscribe

 
Thread Tools
hofer66

 
Member Since: Jun 23, 2011
Location: ibiza :-)
Posts: 3
hofer66 is on a distinguished road
Mac Specs: macbook unibody, 2ghz intel core 2 duo, 2 gb ram, 160 gb hd, osx 10.5.8

hofer66 is offline
hello all,

just signed for this forum and hope i can get some help:

my macbook with osx 10.5.8 does not sound any more, only via headphones. until yesterday all was fine, i sent him to sleep and on reactivating the output source has no output controls any more. headphones work perfectly.
any idea about the problem?
greetings from ibiza, hofer.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,707
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.9, iPhone5s, iPad Air, AppleTV2

mrplow is offline
Restart your Mac.

Option + Click the volume control (top-right near the clock) and choose internal speakers

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
hofer66

 
Member Since: Jun 23, 2011
Location: ibiza :-)
Posts: 3
hofer66 is on a distinguished road
Mac Specs: macbook unibody, 2ghz intel core 2 duo, 2 gb ram, 160 gb hd, osx 10.5.8

hofer66 is offline
did what you said but no way, if i hold option and click on the speaker for the volume nothing happens...
QUOTE Thanks
EvenStranger

 
EvenStranger's Avatar
 
Member Since: Dec 09, 2010
Location: Virginia
Posts: 845
EvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really nice
Mac Specs: Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd

EvenStranger is offline
Try launching GarageBand and see if the app will reload your audio kernel extensions. If not, check the headphone jack on the side and see if a red light is on inside. If so, the plug has defaulted to digital-out. Resetting the PRAM (power off, and immediately after powering on, hold down Command-Option-P-R keys until system chimes 3 or 4 times. Release and let it boot normally.) may resolve the issue. Worst case, the built in audio is bad and requires a system board replacement. Or an inexpensive set of speakers.
QUOTE Thanks
hofer66

 
Member Since: Jun 23, 2011
Location: ibiza :-)
Posts: 3
hofer66 is on a distinguished road
Mac Specs: macbook unibody, 2ghz intel core 2 duo, 2 gb ram, 160 gb hd, osx 10.5.8

hofer66 is offline
did what you said, pram resetted but did not work, red light still sometimes flashes... anyway, i use it mostly with external speakers but as i dj a lot abroad it is useful to listen in the hotel with the internal ones. will buy a pair of small ones to take with me.
thanx again for the great advise, greez from ibiza :-)
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 16,472
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
"red light still flashes" tells me that you have managed to get some debris in the headphone jack (which doubles as an optical jack) that is making the computer think that you have attached optical speakers. A little compressed air or a VERY GENTLE toothpick cleaning should fix the issue.
QUOTE Thanks
twitchymike@mac

 
twitchymike@mac's Avatar
 
Member Since: Feb 24, 2006
Posts: 73
twitchymike@mac has a little shameless behaviour in the past
Mac Specs: G4 + Mac Pro 8-core 6Gb

twitchymike@mac is offline
Dunno 'bout MacBooks, but my Mac Pro has internal speakers or line out, which is your 'phones jack.

Change this options directly in System Preferences ->> Sound. Not the menubar control. That's just up & down. Choose Output section. Choose internal.

Tap the keyboard UP key to ensure the volume's up.

If no luck, your speakers or motherboard amp is broken
QUOTE Thanks
Slydude

 
Slydude's Avatar
 
Member Since: Nov 15, 2009
Location: North Louisiana, USA
Posts: 6,324
Slydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant futureSlydude has a brilliant future
Mac Specs: 2.8 GHz MacBook Pro 10.8,3 8 GB mem, 2.66 GHz Mac Pro - Dead, iPhone 4

Slydude is offline
Quote:
Originally Posted by twitchymike@mac View Post
Change this options directly in System Preferences ->> Sound. Not the menubar control. That's just up & down. Choose Output section. Choose internal.
Option clicking the speaker changes the way that icon behaves. Instead of volume up and down you get a menu showing the same sound inputs and outputs which appear in the sound preference pane. When you use that keyboard shortcut the chug also happens in the Sound preference pane at the sanme time.

Sylvester Roque Former Contributing Editor About This Particular Macintosh

"Got Time to breathe. You got time for music." Denver Pyle as Briscoe Darling
QUOTE Thanks

Post Reply New Thread Subscribe


« Case suggestions? | switching to new mac mini »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Mac Sound Scheme Mr Macintosh OS X - Operating System 2 03-08-2009 12:25 PM

All times are GMT -4. The time now is 10:00 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?