Results 1 to 9 of 9

Thread: Internet Issue

  1. #1

    T_O_P12's Avatar
    Member Since
    Sep 13, 2009
    Location
    Pittsburgh, PA
    Posts
    212
    Specs:
    27" iMac Core 2 Duo, 4GB 1067 MHz RAM, iPhone 4S
    Internet Issue
    On my iMac the internet crawls and works real slow and half the time pages won't load because it is timed out but on every other computer in the house(PC's) the internet flies. How can I fix this or what would be some reasons for this, it is really becoming annoying.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    49,102
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    Which DNS server(s) are you using? If you're using the one from your ISP try switching to OpenDNS and see if that improves things for you. Scroll down the page for the DNS addresses to use.

    Regards.

  3. #3

    T_O_P12's Avatar
    Member Since
    Sep 13, 2009
    Location
    Pittsburgh, PA
    Posts
    212
    Specs:
    27" iMac Core 2 Duo, 4GB 1067 MHz RAM, iPhone 4S
    I am having a problem that is beginning to drive me crazy on my iMac using both Safari and Firefox. When I go to pnc.com it loads fine but when I punch my ID Numbers in to log in, it never loads and eventually after about 5 minutes of trying to load it says the server is not responding. But when I go use a PC in my house that is connected to the same wireless network, it loads fine and there are no problems, any clue or ideas guys?

  4. #4


    Member Since
    Jan 17, 2010
    Posts
    1,466
    Specs:
    2.8 GHz 15" MacBook Pro OS X 10.7.x & some old Macs
    I don't know exactly what is causing your problem but I do know that with wireless connections the location and other electronic interferences can degrade the quality of your connection. Try placing your iMac in the same location as your Windows machines or try moving your router around and see if that solves the problem.

  5. #5

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Test the setup with just the iMac on the network and connected by ethernet to modem. If speed is then Ok then that tells you where to look.

  6. #6

    T_O_P12's Avatar
    Member Since
    Sep 13, 2009
    Location
    Pittsburgh, PA
    Posts
    212
    Specs:
    27" iMac Core 2 Duo, 4GB 1067 MHz RAM, iPhone 4S
    It would sort of be a pain to move my iMac to the basement to test this out but does anyone have any ideas why it would be just this one site that does not work? I have zero problems with other sites.

  7. #7

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,963
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Curious, when you say the site works fine on the PC, which Browser or Browsers are you using there? IE or does Firefox work on the PC also?

  8. #8

    T_O_P12's Avatar
    Member Since
    Sep 13, 2009
    Location
    Pittsburgh, PA
    Posts
    212
    Specs:
    27" iMac Core 2 Duo, 4GB 1067 MHz RAM, iPhone 4S
    That uses IE and on my mac I have tried with both Safari and Firefox and neither works

  9. #9


    Member Since
    Jan 17, 2010
    Posts
    1,466
    Specs:
    2.8 GHz 15" MacBook Pro OS X 10.7.x & some old Macs
    I missed the part about it being just one site you are having problems with. Since you are using IE on your Windows machine it could be that the website requires IE to work. Try going to the site using Firefox on your Windows computer.

    If that doesn't work then you know it blocks other browsers besides IE. One solution to this problem is in Safari you need to turn on the Developer menu in Safari's preferences under the advanced tab section. Once it's on you can choose to identify Safari as IE in the user agent section. This will work for most websites unless the site requires Active X which is IE only.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3G Internet Issue
    By Naff47 in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 02-24-2013, 07:05 AM
  2. internet connection issue
    By h-adzia in forum OS X - Operating System
    Replies: 2
    Last Post: 02-28-2012, 05:12 PM
  3. Internet Connection Issue
    By MrConfused in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 03-20-2011, 10:44 AM
  4. Need help with internet issue
    By Angieg24 in forum Switcher Hangout
    Replies: 1
    Last Post: 01-08-2011, 04:43 AM
  5. Windows 7 Internet Issue.
    By amdxmania in forum Running Windows (or anything else) on your Mac
    Replies: 3
    Last Post: 11-26-2009, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •