Results 1 to 5 of 5
  1. #1

    Member Since
    Mar 04, 2010
    Blackburn, UK.
    MacPorts - does it work?
    I've just installed Emacs using MacPorts, but it turned out to be the Ncurses/terminal version. I tried emacs-app, which I think is the X11/GUI version, and it failed to build. I then tried GEdit, which took hours and then gave a screenful of errors.

    Anyone else used it with any success? MacPorts seems to be a variation of the FreeBSD Ports system - but that does actually work.

  2. #2

    Member Since
    Feb 25, 2009
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    I've used it for several things - of course, I don't just use MacPorts - I use the gui front end Porticus to do my installs, and what I've installed has installed just fine... For many/most things you need to make sure you have XCode installed tho AFAIK so whatever is downloaded can be properly compiled if required.
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  3. #3

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    2012 13" MBP (2.5 i5, 8GB)
    Works about 95% of the time here for me.

    As for emacs, give Aquamacs a try. For gedit, there are native Mac builds - get it here (look for the link on the right hand side).
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  4. #4

    IvanLasston's Avatar
    Member Since
    Feb 26, 2010
    Rocky Mountain High, Colorado
    1.8 GHz i7 MBA 11" OSX 10.8.2
    It works most of the time for me. As stated before I have xcode and x11 installed.

    I just tried installing xemacs and it seems to work. I had to turn off universal though
    sudo port install xemacs -universal

  5. #5

    Member Since
    Mar 04, 2010
    Blackburn, UK.
    Maybe I was just unlucky, or it was user error from a Mac novice.

    Quote Originally Posted by vansmith View Post
    As for emacs, give Aquamacs a try.
    That's a top tip, thanks for that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. done something silly with macports
    By stupid in forum OS X - Development and Darwin
    Replies: 0
    Last Post: 02-04-2011, 01:24 AM
  2. MacPorts problem
    By pepsiboy in forum OS X - Development and Darwin
    Replies: 0
    Last Post: 04-04-2010, 12:53 PM
  3. libtool in MacPorts
    By detonator413 in forum OS X - Operating System
    Replies: 0
    Last Post: 10-31-2009, 07:25 PM
  4. gcalcli and macports
    By aarnclayt in forum Running Windows (or anything else) on your Mac
    Replies: 6
    Last Post: 08-21-2008, 08:54 AM
  5. Help with macports
    By cradom in forum OS X - Development and Darwin
    Replies: 0
    Last Post: 01-20-2008, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts