Hey guys, today utorrent was stuffing up, for example the left panel disappeared and i couldnt get it back. l went to file and tried all the options i could but couldnt find an actually options part of utorrent, to fix the problem. So out of frustration i deleted it, everything i could find of it.
a week before this some of the information on an item thats downloading, eg. the bar that shows the percentage done, name of the file, how much time its got left etc. disappeared aswell.

So now when i go to download it again, either the beta or alpha versions, it starts to download then stops and come up with safarierrordomain error 2, i have a look at it in finder and it comes up as not recognised on disk image or something close to that.

I was just wondering how do i fix this please?
Thanks for your help

I double click on the disc image but it comes out with a warning and says its not recognised. its not really like a virus big alert warning just a warning that it wont open.
i tried opening it with disk utility and repair **** but im not sure what thats does but i still double click on it and it comes up with the same "not recognised" warning.
I called Mac suppor in australia cause thats where i live but they said maybe download it from another source but i havent being able to find a reliable mac download source for utorrent, other than tha mac support didnt say much else.

Just wondering maybe if anyone on Mac forums could help me please.
thanks for your help and time