Results 1 to 11 of 11
  1. #1


    Member Since
    Apr 01, 2009
    Posts
    6
    Mac Has Locked Me Out of All My Drives
    Disaster has struck!! My Mac has currently locked me out of my 2 external drives and 1 internal drive, and I can't access a single file. My entire life is locked into these drives with no access, and all because I ticked one box in Leopard!! Even after a total re-install of the operating system this one ticked box from the previous OS has created total destruction!

    What happened was I recently networked my G5 to a macbook with the latest version of Leopard. Aftwrewards, I noticed that even though I had set the permissions on all of my drives for another user to access from the macbook, most of the files inside had not updated with this permission. Even when I set permissions on a folder, each file inside the folder ignored the permission and only worked if I set them up one at a time.

    So I highlighted a folder, clicked info and this time when I set the permissions I went to advanced and then ticked the "Apply to Enclosed Items" box.

    This resulted in locks appearing on every drive, and the macbook was locked out from accessing my drives on the network.

    So I stupidly tried clicking on my main drive and choosing the same "include everything" options. Then when I rebooted, the system failed to load.

    I just get a grey screen with the apple logo. No spinning wheel. Nothing.

    I had to force eject the drive with the old paperclip in the DVD routine, insert the system disk and then boot from that.

    After spending most of last night trying to find a solution on the internet, i decided to reinstall my original Leopard 10.5.6 disk on my main drive this morning. I erased the main disk, reinstalled and all booted up.

    But now I am locked out of every other drive except my main drive! When clicking on either my external drives or my second internal drive I get a message box that says "You do not have sufficient access priviledges."

    When I open the info box for each drive they all say custom access. No matter what I try and set each of these too, it just switches back to custom access.

    Disk utility doesn't help either. The verify permissions box is greyed out so I can't click on it.

    Help!!! Everything I've ever saved is on these drives and I've spent all day trying to fix it. Booted in single user mode and entered commands. Gone into terminal and entered commands, all found on various forums with people who have had the same problems.

    Nothing works!!!

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,260
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    Quite a mess. The only solution I can offer is to try logging on to the machine as a Super User (ROOT) and see if that will allow you to change permissions on those external drives. See the following Apple KB article to learn how to implement the ROOT account: Link

    If that doesn't work, you may need a third party solution to access those drives at low level. Something like "Data Rescue II" may be helpful. Link

    I could suggest Unix commands to use from Terminal, but that may make matters worse since I don't know what was changed by you previously.

    Regards.

  3. #3

    rman's Avatar
    Member Since
    Dec 24, 2002
    Location
    Los Angeles, California
    Posts
    12,584
    Specs:
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    Cool
    To resolve your problem you will need to run the terminal application (Macintosh HD -> Applications -> Utilities -> Terminal).

    In that window you are going to do a series of unix commands (df , ls -l, cd, and chmod).

    First do a df (display free disk space), this will show you your mounted file systems (disks). In may case I see the following:

    df
    Filesystem 512-blocks Used Available Capacity Mounted on
    /dev/disk0s2 976101344 191243400 784345944 20% /
    devfs 223 223 0 100% /dev
    fdesc 2 2 0 100% /dev
    map -hosts 0 0 0 100% /net
    map auto_home 0 0 0 100% /home
    /dev/disk1s2 976101344 346035376 630065968 36% /Volumes/Mac HD
    /dev/disk3s2 976101344 187774048 788327296 20% /Volumes/Macintosh HD 2
    /dev/disk2s2 209453056 190401960 19051096 91% /Volumes/Macintosh HD BK
    /dev/disk2s3 766386144 374125800 392260344 49% /Volumes/Mac HD 3

    As you can see my extra disk are under the directory of /Volumes. Your should show up simliar to this.

    Move into the directory /Volume by doing a cd /Volume (cd - change directory). Then get a directory listing (ls), ls -l.

    You should see something like this:

    ls -l
    total 8
    drwxr-xr-x 25 rman rman 918 Mar 24 17:43 Mac HD
    drwxr-xr-x 21 rman rman 782 Jan 22 06:52 Mac HD 3
    lrwxr-xr-x 1 root admin 1 Mar 31 18:31 Macintosh HD -> /
    drwxrwxr-t 32 root admin 1156 Jan 20 23:35 Macintosh HD 2
    drwxrwxr-t 32 root admin 1156 Feb 3 07:09 Macintosh HD BK


    You are now going to change the permissions on your external drives, do not mess with your system drive (Macintosh HD, default name).

    Since you touch all of the files on the drive, we are going to open it up for everybody to be able to read and write. Thi is to resolve the problem quickly, you can go back an reset the permission to what you want later.

    My drives are Mac HD, Mac HD 3, Macintosh HD2, and Macintosh HD BK. To change permission do the following, don't for get the quotes due the space in the directory name.

    You don't need root to complete this task, when sudo will do.

    sudo chmod -R 1777 "Mac HD" "Mac HD 3" "Macintosh HD2" "Macintosh HD BK"

    The 1777 is going to chamge all files and directories to rwxrwxrwt. Which means read, write, execute, and t for sticky bit.

    The first rwx is for the owner of the directory/file, the second rwx is for the group, and the last rwx/t is for other (anybody).
    -R option mean to start from the top most to the bottom.

    Hopefully this will help to get you access to your data.
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

  4. #4

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,260
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    It's always good to see someone who has knowledge of Unix commands. Great solution for the OP. It would have taken me an hour to look up all those commands and write them down.

    To winklepicker: Make a print out of rman's reply and follow it closely. Keep in mind that all Unix commands are "case sensitive". Good luck with the fix.

    Regards.

  5. #5


    Member Since
    Apr 01, 2009
    Posts
    6
    Thanks everyone for your help.

    rman I really appreciate you taking the time to help me like this. It means a lot.

    I followed your instructions to the letter. I cut and pasted all commands and inserted the names of my drives where appropriate. However, the drive I am trying to change has remained untouched. Here is the before and after of everything I did as re your instructions.

    DISPLAY FREE DISK SPACE RESULTS:-

    Filesystem 512-blocks Used Available Capacity Mounted on
    /dev/disk0s3 312319584 24355336 287452248 8% /
    devfs 216 216 0 100% /dev
    fdesc 2 2 0 100% /dev
    map -hosts 0 0 0 100% /net
    map auto_home 0 0 0 100% /home
    /dev/disk1s3 312319584 308463032 3856552 99% /Volumes/VIDEO
    /dev/disk2s3 14816560 14752696 63864 100% /Volumes/Mac OS X Install DVD


    ls -l RESULTS:-


    total 8
    lrwxr-xr-x 1 root admin 1 1 Apr 18:03 MAIN -> /
    drwxrwxr-t 24 robwillis staff 884 6 Jan 02:33 Mac OS X Install DVD
    drw-rw-r-T 30 robwillis 501 1088 24 Mar 19:06 VIDEO


    PERMISSIONS CHANGE:-

    rob-williss-power-mac-g5:Volumes robwillis$ sudo chmod -R 1777 "VIDEO"

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    Password:

    My password is set to blank by the way, so I just hit return. When I then typed in ls -l again, nothing had changed.

    rob-williss-power-mac-g5:Volumes robwillis$ ls -l
    total 8
    lrwxr-xr-x 1 root admin 1 1 Apr 18:03 MAIN -> /
    drwxrwxr-t 24 robwillis staff 884 6 Jan 02:33 Mac OS X Install DVD
    drw-rw-r-T 30 robwillis 501 1088 24 Mar 19:06 VIDEO


    Clicking on the drive outside of terminal brings up the same insufficient access privileges dialogue box and all my permissions remain at custom and will not change.

  6. #6

    rman's Avatar
    Member Since
    Dec 24, 2002
    Location
    Los Angeles, California
    Posts
    12,584
    Specs:
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    Cool
    i believe you do have an admin pass word.

    do the sudo chmod -R 1777 VIDEO

    put in your admin pass word - that is the one you use to install software to your system
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

  7. #7


    Member Since
    Apr 01, 2009
    Posts
    6
    When I installed Leopard and it asked me to enter an admin password against my name I just hit return. It then told me that I was choosing to leave the password blank, but I accepted it anyway. That way I don't have to keep entering a password everytime I want to add software or make changes.

    I'm regretting it now, but the password field is definitely set as blank.

    I have also tried logging on as a Superuser following the suggestions and links posted by chscag. I can view the files on the drive now but when I try to change permissions I get:

    The operation could not be completed. An unexpected error occured (error code -50).

    I can copy files from my locked out VIDEO drive to my MAIN drive so it's an improvement of sorts. However, I have a 1 Terrabyte hard drive that is full that I would have to copy over to another drive and then reformat.

    I'm amazed that such a simple mistake on my part (ticking a check box) could have such massive ramifications.

    So far your suggestions are certainly soothing my stress!!

  8. #8


    Member Since
    Apr 01, 2009
    Posts
    6
    Okay, I set a password and found that Terminal responds now. If no password is set on your Mac the terminal won't accept the carriage return as an indication of no password.

    So I tried the whole process again, and this is what I get.

    sudo chmod -R 1777 "VIDEO"

    "Operation not permitted"

    Incidentally, I've been looking on the Apple forums and found quite a few people with the same problem. So far, nobody has managed to solve this problem. I don't understand why.

  9. #9


    Member Since
    Apr 01, 2009
    Posts
    6
    I finally found the problem.

    First off, terminal has not been responding to the fact I had no password set for my admin account. So I set one. Then I went back to an old posting on the Apple forums that suggested entering this in the terminal.

    sudo chflags 0 /Volumes/*

    sudo chmod a+x /Volumes/*

    This worked perfectly and has so far unlocked 2 out of the 3 drives. However, one last drive is refusing to co-operate. The name of the drive is DV TAPES. When I enter this in the terminal it splits the words into DV and says there is no such volume and TAPES saying there is no such volume. I've tried putting an underscore between the two words but nothing.

    The drive comes up in the directory list in terminal as DV TAPES. All in caps, with a space and exactly as I am typing it.

    How can I make terminal find this drive?

  10. #10

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,900
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Worked for me. Say your drive is WD COMBO like one of mine is. you put in WD then hit the TAB. It will complete the entry and put in the proper info which in my case was WD\ COMBO/

    Let me know if that works. It's a good idea to not uses spaces in hard drive names in a unix system. Makes it so much easier if you do not.

    Try the TAB key right after DV and if that does not do it try DV\ TAPES/

  11. #11


    Member Since
    Apr 01, 2009
    Posts
    6
    It worked!!! Thanks so much dtravis 7. Now my last (and biggest drive) is unlocked!!!

    Now to reinstall all my operating system again on the main drive

    Really appreciate everyone's help with this.

    Just one last question - the thing that triggered this nightmare in the first place was just by trying to set privileges on each drive for another user on a macbook to access via a wireless network.

    Permissions were set - so it seemed - on each drive, but every folder and file inside the drive failed to set the same privileges. Even individual folders with the right user set wouldn't seem to take effect on each file enclosed within.

    So I ticked the dreaded "includes" check box on one folder, and this is how all my drives locked off one after the next.

    So how do I give a network user access to all files on a drive without having to set it file by file?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie to Terminal-Locked hard drives help.
    By jwalte in forum OS X - Operating System
    Replies: 5
    Last Post: 04-08-2011, 07:49 AM
  2. Help: Int/Ext Drives Locked!
    By nekokano in forum OS X - Operating System
    Replies: 3
    Last Post: 07-05-2010, 11:41 PM
  3. rip locked super drives
    By rdsii64 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 03-22-2008, 04:23 PM
  4. Locked Drives
    By simbey1982 in forum Switcher Hangout
    Replies: 5
    Last Post: 03-02-2005, 12:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •