Results 1 to 9 of 9
  1. #1
    shawnskills
    Guest
    Lost in Bangkok, formatting external Hard disk
    Ok...I'm in need of assistance. I have an ibook G4 bought last year and am running OS 10.3.8. I just bought a new 80GB external hard disk so I could dump all my imovie projects onto and not hog up the hard drive on my laptop. However, here lies the problem. The hard disk apparently needs to be 'formatted' and so I have studied the process of doing this on line (using disk utility, tabbing to the 'erase' field, re-naming the volume, and formatting using MAC OS (journaled). But once it's done all that, I still get no icon appearing on my desktop for my connected hard disk. It's on firewire and when I plug it in, my mac reads it and says it needs to be 'initialized' (which I have just mentioned trying to do). But, as I said, after initializing, nothing happens, even though in 'Disk Utility' I can see the icon in the left window. When I took it in to the store (here in Bangkok) they formatted it for me using a PC, then plugged it into my Mac and then it worked (I saw the icon on my desktop). But when I tried to copy my iMovie files, it said there was an error and it can't recognize the file. So this lead me to believe that it was formatted using a PC Mac exchange format and not the MAC OS (journaled) one I need. So again, when I tried to format it the 'MAC' way, the icon for the disk on my desktop disappeared and I was back to square one. Please, someone help if you can..I think I've spent hours trying to do this on my own..to no results. And there is not a lot of help out here in the East!
    Much much appreaciated if anyone has ANY idea what's going on here.

  2. #2
    Lost in Bangkok, formatting external Hard disk
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    in th finder, click GO>Computer, if the hd is shown there, open disk utility and see if its shown in the list on the left, click 'mount' on the top area of the window.

  3. #3
    shawnskills
    Guest
    Well, it is in the left window of the Disk Utility, and the 'mount' button is clickable, however, nothing happens when I click it.
    Also, when I'm in Finder and click on 'go' then 'computer' the hard disk isn't there..no icon...strange, as Disk Utility picks it up.

  4. #4
    Lost in Bangkok, formatting external Hard disk
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    hmm, whats it named? if you didnt rename it at reformatting, it wont show up. make sure the name is all letters, no symbols, numbers, or spaces.

  5. #5
    shawnskills
    Guest
    I tried that...no go. I just named it HD2, but when I click 'erase' it's like it doesn't like the name or something..and renames it 'disk2s3'. This is maddening. The guy who apparently formatted it for me did it on a PC and it worked when I plugged it back into my ibook. But I didn't realize until later that it wasn't formatted as MAC OS (journaled) so I can't copy my files onto it.

  6. #6
    Lost in Bangkok, formatting external Hard disk
    Aptmunich's Avatar
    Member Since
    Mar 09, 2004
    Location
    Munich
    Posts
    9,073
    Specs:
    Aluminium Macbook 2.4 Ghz 4GB RAM, SSD 24" Samsung Display, iPhone 4, iPad 2
    I had that same problem with iMovie files - for some reason they won't live on FAT32 (PC formatted drives)...

    Have you tried rebooting after formatting?

    Or repair permissions? Theoretically it should all work - I have the exact same setup as you?

  7. #7
    shawnskills
    Guest
    I tried rebooting but doesn't do anything...when it logs in it just says the same thing "you have inserted a disk that OS X does not recognize, would you like to initialize the disk?" so it's like starting all over again.
    Reparing Partitions doesn't do anything either..

    HELP!!!

  8. #8
    Lost in Bangkok, formatting external Hard disk
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    when it says that, click initialize, and try just mac os extended, not journaled, then after initializing it, select it in the list, though it should already be selected, and click mount.
    after it mounts, quit disk utility, open syatem preferences>accounts, select your admin account, click startup items tab and drag the mounted disk to the list. this will make it mount at start up. eject that disk, restart, and see if it shows up. if not, it may be a hrdware problem,how good are you at hard drives and such? hardware?

  9. #9
    shawnskills
    Guest
    the problem there is that when the disk is highlighted and I try to mount it, nothing happens and the info at the bottom of disk utility says the disk is not mounted (even after I've pressed the mount button).
    It just seems strange to me that it appears in the left window of Disk Utility though not on the desktop.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help for files lost (?) from an external hard disk
    By bob rock in forum OS X - Operating System
    Replies: 0
    Last Post: 04-07-2012, 04:18 AM
  2. Formatting an external disk?
    By Jonzjob in forum Apple Desktops
    Replies: 7
    Last Post: 05-17-2010, 04:14 PM
  3. alterative to disk utility for formatting external hard drive
    By cardamom in forum OS X - Operating System
    Replies: 2
    Last Post: 09-12-2009, 07:25 PM
  4. Running OSX and XP Hard Disk Formatting Question
    By spartykjc5389 in forum Running Windows (or anything else) on your Mac
    Replies: 6
    Last Post: 06-26-2007, 03:23 PM
  5. Formatting hard disk queries
    By poisoncell in forum Apple Notebooks
    Replies: 4
    Last Post: 01-21-2006, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •