Results 1 to 8 of 8
  1. #1


    Member Since
    Oct 16, 2008
    Posts
    2
    Unhappy Internet Browser Painfully Slow
    I'm a Mac newbie. I just bought an 2.4 GHz Intel Core 2 Duo iMac with Leopard 10.5.5, and I immediately added 2 GB of RAM (now 3GB total).

    While it seemed to work okay out of the box, it now takes 2-5 minutes to load a web page, if the page even loads at all. Often the progress bar freezes halfway across, or I get something like a "failed to load page" message. My old Toshiba laptop (with all sorts of junk loaded on it), on the other hand, loads the same pages just fine (in a few seconds). I have doubts it's one of the few additional apps I've installed to this point.

    -- I've tried both Safari and Firefox.
    -- I've tried connecting to my router via ethernet instead of Airport.
    -- I've tried using different Static IP addresses instead of the auto setting.

    I am BEYOND frustrated and am about ready to declare my brand new iMac to be little more than a boat anchor. I'm not sure where to go next. Any thoughts are welcome!!

  2. #2

    hughvane's Avatar
    Member Since
    May 18, 2008
    Location
    Banks Peninsula, Canterbury
    Posts
    3,326
    Specs:
    MacMini 4.1, OS 10.11 and 10.6; Macbook Pro 8.2, OS 10.11, MacBook 4.1, OS 10.6.8
    See the response to your post on another forum.

  3. #3


    Member Since
    Oct 16, 2008
    Posts
    2
    Wow--You're everywhere! Thanks

  4. #4

    hughvane's Avatar
    Member Since
    May 18, 2008
    Location
    Banks Peninsula, Canterbury
    Posts
    3,326
    Specs:
    MacMini 4.1, OS 10.11 and 10.6; Macbook Pro 8.2, OS 10.11, MacBook 4.1, OS 10.6.8
    Quote Originally Posted by Canoetripper View Post
    Wow--You're everywhere! Thanks
    Just think of me as 'hugh-biquitous'

  5. #5


    Member Since
    Aug 17, 2008
    Location
    Napier, New Zealand
    Posts
    8
    Specs:
    2.0 Ghz Unibody 13" MacBook, Mac Mini 1.42 GHz, 1GB ram, iPod 16GB Touch, 30GB iPod Classic
    Would someone tell me what the issue was or point me to the other forum where this is discussed?

    I'm just curious to see what the problem would have been.

    Thanks!

  6. #6


    Member Since
    Aug 22, 2008
    Posts
    181
    me too...

  7. #7

    hughvane's Avatar
    Member Since
    May 18, 2008
    Location
    Banks Peninsula, Canterbury
    Posts
    3,326
    Specs:
    MacMini 4.1, OS 10.11 and 10.6; Macbook Pro 8.2, OS 10.11, MacBook 4.1, OS 10.6.8
    Quote Originally Posted by PearlJamFan View Post
    Would someone tell me what the issue was or point me to the other forum where this is discussed?
    I'm just curious to see what the problem would have been.
    Mac Forums - Mac News and Rumor Discussion > Mac Basics & Help

    [M-F Mods - please don't excommunicate me, I'm too old for that ]

  8. #8


    Member Since
    Aug 17, 2008
    Location
    Napier, New Zealand
    Posts
    8
    Specs:
    2.0 Ghz Unibody 13" MacBook, Mac Mini 1.42 GHz, 1GB ram, iPod 16GB Touch, 30GB iPod Classic
    Quote Originally Posted by hughvane View Post
    Mac Forums - Mac News and Rumor Discussion > Mac Basics & Help

    [M-F Mods - please don't excommunicate me, I'm too old for that ]
    Many thanks for the info hughvane, that was an interesting thread.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Painfully slow downloading newsgroup
    By riksworld in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 08-06-2011, 10:17 PM
  2. iPhoto runs painfully slow
    By Qslim in forum Images, Graphic Design, and Digital Photography
    Replies: 1
    Last Post: 07-23-2011, 02:09 AM
  3. Internet speed good - browsers painfully slow
    By twhitenack in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 08-24-2010, 10:25 PM
  4. Painfully Slow Networking on Leopard
    By ostuneup in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 09-26-2008, 04:17 PM
  5. Painfully slow internet
    By jmsheahan in forum OS X - Operating System
    Replies: 4
    Last Post: 06-21-2008, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •