Results 1 to 9 of 9
  1. #1


    Member Since
    Sep 27, 2008
    Posts
    3
    A slooooooooow Mac.
    I installed the latest version of OS X about a week ago and my Mac has been really slow ever since. Barley faster than Dial-up . I have broadband internet. Does anyone know what happened? Thanks.

  2. #2

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,907
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    What Mac do you have? What are it's specs? I take it you installed Leopard?

    What speed is the CPU? How much RAM?

  3. #3

    skaheadpunk's Avatar
    Member Since
    Jan 12, 2008
    Location
    Leicester, England
    Posts
    1,760
    Specs:
    MacBook, iPod Classic, 8GB 3G iPhone, Time Capsule
    You mean your computer is slow or the internet is slow?

  4. #4

    Spork's Avatar
    Member Since
    Jul 17, 2008
    Location
    Arizona
    Posts
    182
    you might just have an older mac without any additional hardware put in so the computer might be slow because of that, post your specs and we will see.

    Is it the whole computer that's slow or like skahead said is it only slow when you're online?

  5. #5


    Member Since
    Sep 27, 2008
    Posts
    3
    Sorry guys I'm a full on idiot when it comes to this stuff. I'll try and answer your questions the best I can.

    When I say my Mac. is slow I mean the internet is slow I think everything else so working ok.

    I don't know if I installed Leopard or not. I went to log onto the internet and a thing came up and said something like "Software updates are available, would you like to install"? I clicked on "Install" it took about 20 minutes or so. Then after that when I try to open a page on the internet it takes forever to open.

    This is what I have:

    Safari version 3.1.2

    Processor:2 GHz intel core z Duo

    Memory: 1 GB

    Startup Disk: Mac. HD

    Model indentifier: iMac5,1

    Processor name: intel core 2 Duo

    Processor speed: 2 GHz

    # of processors: 1

    Total # of cores: 2

    L2 cache (pre processor): 2

    Bus speed: 667MHz

    Boot ROM version: IM51.0090.B09

    SMC version: 1.8f2

  6. #6

    skaheadpunk's Avatar
    Member Since
    Jan 12, 2008
    Location
    Leicester, England
    Posts
    1,760
    Specs:
    MacBook, iPod Classic, 8GB 3G iPhone, Time Capsule
    If you go to Apple> About this Mac, it'll tell you what version of OS X you're running - mine's 10.5.5. I'm guessing yours is too.



    And since it's an 2Ghz iMac it shouldn't have any trouble with Leopard. Could have been the update from 10.5.4 to 10.5.5 though I guess, if that's the only thing that's changed.

  7. #7

    Alexis's Avatar
    Member Since
    Apr 20, 2006
    Posts
    2,255
    Specs:
    Al iMac 20" 2.4Ghz Intel Core 2 Duo
    Please tell us how you're connecting to the internet.

  8. #8


    Member Since
    Sep 27, 2008
    Posts
    3
    I have Mac OS X version 10.4.11

    I am connecting to the internet through a cable modem.

  9. #9


    Member Since
    Jan 06, 2008
    Location
    Hillbank, South Australia
    Posts
    323
    Specs:
    2 x 20" iMac Intel Core 2 Duo
    Well Leopard is 10.5 so 10.4.11 is Tiger so you don't have Leopard.
    Download either firefox 3 browser or webkit browser and see if the internet is still slow.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •