New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Showing results 1 to 3 of 3
Search took 0.00 seconds.
Search: Posts Made By: 4Steve
Forum: OS X - Operating System 10-23-2011, 08:34 PM
Replies: 6
Views: 2,321
Posted By 4Steve
Hi, I'm also finding Aperture running really...

Hi,
I'm also finding Aperture running really slow, it's driving me nuts:Shouting:
I have an iMac with 2GB 800MHz DDR2 SD RAM, what are my options ?
Is it easy to replace RAM myself, I've seen a...
Forum: OS X - Operating System 11-02-2009, 10:10 PM
Replies: 2
Views: 1,910
Posted By 4Steve
Cool :Cool:All ok now, I did install SL but this was a...

:Cool:All ok now, I did install SL but this was a bum steer as I upgraded all my software at the same time, turns out iMovie 09 8.0.5 is the problem, once I dragged 8.0.4 back from time machine all...
Forum: OS X - Operating System 11-01-2009, 07:53 PM
Replies: 2
Views: 1,910
Posted By 4Steve
Unhappy iMovie crashes since I installed Snow Leopard!

:Confused:Hi, I am desperate for help, I have installed Snow Leopard on my iMac, all seemed fine until I fired up iMovie which after a while just crashed giving the message "lib3ivxEnc.dylib plugin"....
Showing results 1 to 3 of 3

 
Forum Jump

All times are GMT -4. The time now is 05:31 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?