New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Schweb's Lounge Forum for general conversation, chit chat, or most topics that don't fit in another forum.

What the heck with my mouse...


Post Reply New Thread Subscribe

 
Thread Tools
moosegoose
Guest
 
Posts: n/a

Hey, I have a "mighty mouse" or whatever that came with my iMac and also an MX 1000. Obviously, the mx would be choice to use seeing as how it cost me $80 in the first place and uses laser instead of optical. However, it doesn't feel the same at all compared to the stock Apple mouse. It feels like is drags alot more across the screen compared to what came with the iMac, is there a way to fix this? It's far more accurate when working in Photoshop and what not so I would like to get to the bottom of this. Thanks in advance.
QUOTE Thanks
Graphite

 
Graphite's Avatar
 
Member Since: Feb 25, 2003
Location: Tropical Island, Jealous?
Posts: 5,279
Graphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud of
Mac Specs: MacPro 3.0Ghz 16GB RAM, 4x256 Vid, 30''cinema display

Graphite is offline
I am not entirely sure what you mean drags a lot more across the screen. Have you checked system preferences and turned up the speed? Or there could be interference in your wireless connection? Or it could be because the MX 1000 is much more accurate when going across the surface that rather than skipping pixels it goes over every one...
QUOTE Thanks
moosegoose
Guest
 
Posts: n/a

Yeah, even when the sensitivity is up at max, the mouse still slowly and lazily moves across the screen. It's a straight shot from the mouse the the charger as well. It doesn't jitter around and miss pixels, it still get's all of them...it also almost feels like there is mouse lag (if you are familiar with games on PC's).
QUOTE Thanks
Graphite

 
Graphite's Avatar
 
Member Since: Feb 25, 2003
Location: Tropical Island, Jealous?
Posts: 5,279
Graphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud of
Mac Specs: MacPro 3.0Ghz 16GB RAM, 4x256 Vid, 30''cinema display

Graphite is offline
You installed all the software? (I know most mouses work with out extra software, even though some is included) You could always try it on another computer? Load up Activity monitor, and see if you can tell anything from there.. RAM/CPU consumption? I really have never had problems with a logitech mouse before, could be a malfunction? or could be your intel mac isn't working smoothly with it... wait for more firmware and software updates? :biohazard
QUOTE Thanks
moosegoose
Guest
 
Posts: n/a

Well, I just checked it again. Feels fine now...I guess the whole feel of mice in OS X is different in the first place (I just switched from PC's to Mac a little over a week ago).
QUOTE Thanks
Graphite

 
Graphite's Avatar
 
Member Since: Feb 25, 2003
Location: Tropical Island, Jealous?
Posts: 5,279
Graphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud of
Mac Specs: MacPro 3.0Ghz 16GB RAM, 4x256 Vid, 30''cinema display

Graphite is offline
Ah ok, good glad to hear its not a huge problem.
QUOTE Thanks

Post Reply New Thread Subscribe


« Ripping a website | Palm / iSync / Markspace »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
One-button mouse keeping you on the fence? Meyvn Switcher Hangout 12 02-10-2005 12:46 AM
has your pro mouse quit? Look! jasonr Other Hardware and Peripherals 4 11-21-2003 03:50 PM

All times are GMT -4. The time now is 10:31 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?