Results 1 to 5 of 5
  1. #1
    Download 44mb SIT file & Folder is empty HELP!
    I have downloaded a 44 MB SIT file from's website. It is for a program called Nikon View. I unpacked it using stuff-it and the folder is empty. I deleted the download and re-downloaded. It happened again. I have done 3 reboots, tried it on two different days, and tried a total of 8 times and had the same results. Does anyone know why or how to fix this? I also learned that this happens to someone else but not as much.
    44mb Sit file
    PowerBook 1.67 512mb ram
    52 gigs left on my primary hard drive.

  2. #2
    Can you point us to the sit file?

  3. #3
    Here is the one I uploaded. Nikon has this annoying registration thing. Here is mine: and then here is Nikon's: All their downloads are there.

  4. #4
    Actually I got it to work by unpacking it into my documents folder.

  5. #5
    Great. I apologize I meant to check it this morning but forgot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please answer a ? about download file & iphoto
    By LondosLady in forum OS X - Operating System
    Replies: 2
    Last Post: 06-28-2011, 02:57 AM
  2. Do I empty my bursting download folder?
    By horatio in forum OS X - Apps and Games
    Replies: 7
    Last Post: 01-07-2011, 01:33 PM
  3. Empty unpacked .sit folders?
    By JSchultz in forum Switcher Hangout
    Replies: 8
    Last Post: 02-04-2007, 04:22 PM
  4. .sit file?
    By ARC in forum Switcher Hangout
    Replies: 9
    Last Post: 12-24-2006, 09:33 AM
  5. Help with a .sit file
    By BlindingLights in forum Switcher Hangout
    Replies: 1
    Last Post: 03-01-2006, 05:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts