Results 1 to 4 of 4
  1. #1

    Member Since
    Jun 28, 2007
    zip drive & performa
    I finally decided to give up my old performa, but wanted to save some files from it. Everytime I try to connect the zip drive, it powers off. If I connect the zip before I turn it on, it won't turn on. I have pulled out the mother board and cleaned all the dust bunnies from nooks and crannies, but it didn't help. Suggestions?

  2. #2

    Mac SK's Avatar
    Member Since
    Oct 20, 2006
    If its a SCSI zip drive there is a SCSI id number switch on the back.No two devices can have the same id. And you need the iomega drivers installed.

  3. #3

    Member Since
    Jun 28, 2007
    I guess I'll just have to give it up. I have no idea where the modem is to download a driver. Thanks for taking the time to answer!

  4. #4

    Brown Study's Avatar
    Member Since
    Mar 11, 2004
    G4 Tiger and OS 9
    As I recall, a Zip didn't really need drivers to show up on the desktop after a boot.

    Maybe it was hit with the Click of Death.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Locking a zip drive
    By jonesy16 in forum OS X - Operating System
    Replies: 3
    Last Post: 04-01-2010, 05:35 PM
  2. New use for zip drive bay
    By spaceratk in forum Switcher Hangout
    Replies: 3
    Last Post: 05-28-2008, 02:41 AM
  3. Using Zip Drive with imac
    By barbp in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 11-20-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts