I am trying to use a laptop to connect to a tower remotely.
The Remote Desktop app won't wake a computer from sleep, unless it is on the same subnet. If I have the laptop at my house, and type in my tower's external (or internal) IP address, that computer will be added to the "computers list" in the program and the program wakes my tower. It won't wake a different tower on a different subnet though from here (it won't add it to the "computers list", but it will connect if the other computer is already awake. The same applies at his the other location in reverse - won't wake mine but wakes that tower with an internal or external IP typed in.
I have gone through all the enable wake admin settings, not putting the computer to sleep, just the hard disk, etc., so I don't think it is a setting like that.

There is a knowledge base article saying you can't wake a client computer that is behind an airport, but the client computers are hardwired. It is only the admin that is wireless. I tried to get rid of this as being the problem by hardwiring the laptop at his house onto the lan, bypassing the airport, and it still wouldn't wake a computer out of the subnet. It seems to be a firewall issue on the router, but I have the appropriate port forwarded and can't figure out what to do. Any ideas would be appreciated.