So I downloaded all the updates and firmware, ect, and partitioned my drive.

At first, it told me I had an error on my drive, and to run Disc Utility to repear it. I did, it was repeared. Then I partitioned it, and started the intall of windows.

Went through the steps, and it was "copying installation files" and EVERYTIME (I did this about 10-15 times, for seven straight hours) it would stop at 57% and just freeze. It wouldnt copy the file. Every once in a while, maybe 1 out of 5 times, it would say "Windows cannot copy the file. Would you like to RETRY or SKIP this file?"

Retry just fails. So I skipped. Then the same thing happened to about 12 more files, saying the cant be copied, so I skipped them.

Well, of course, without these files, windows wouldnt install, so the actual set-up/installation failed.

My CD is BRAND NEW and in perfect condition, so, that couldnt be the problem. I tried to install it on another Macbook, and it worked perfectly, installing windows just fine.

So who knows what the problem is? A way to fix it? Or perhaps by-pass it? Maybe copying the entire partitioned harddrive (just the windows partition) that sucessfully installed on the other computer? Would that even work? What about copying just the "Copied installation files" that failed to install on mine?